A Mystery Attack (quest) water pail bug

This quest halts the entire main scenario quest line. Quest requirements done up to when a pail of water is needed to put the fire out. I can grab the pail but when I go to the fires I can’t use the pail on the fire. This quest holds up all progression. Please help…

By the way, I checked file integrity through Steam and all files for this game are okay.
Thanks, in advance, for your help.

Saaaaame. I threw the pail the instead of splashed and it just destroyed the pail, says I put out the fire but there are no bandits showing up and I can’t pick up any more pails

You can’t abandon Main story quests to start them over either

I also have this bug. I can’t continue the storyline nor can I abandon it. Please help.

Its not a bug. Idk why this quest does it but if you read the tooltip it asks you to defeat gravediggers. Basically there are some flies a little bit north of the fire, kill 3 of em and you should be good to go!

1 Like

This fixed it, thanks!

1 Like

This did not work for me, pail is still bugged after killing the 3 Gravediggers.

1 Like

Hi folks.

Same issue here. 2nd character I’m doing this with. Pale of water has been thrown and that is checked off but killing gravediggers will not trigger any progression. Stuck in the main quest as of now. Anyone have any ideas?


Leaving the zone and entering again seemed work for me

I have the same issue, it wont throw the pail of water, it gets stuck in front doing literally nothing.
EDIT : i spamed ALT + right click it worked

1 Like

My bad. You have to hit “q” to throw the pail, then “LEFT click” on the location where you want to throw it.


I had to spam the button a bunch to get it to work, spam left click a bunch and if that doesnt work spam right click, don’t remember which one I used I just know I pressed it a bunch and I eventually threw the water.

After you pickup the bucket, your attack key ie. Q, W etc one of them changed to throw…

Doh! This is the answer.