Absolute strength tripod on destroyer is currently bugged

its not just visual, have done tests in trixion and it literally doesnt make any difference if its selected or not, it literally increases damage by 0%

1 Like

Yeah i notice that too, pls fix asap, this is our strongest skill…

Yep I tried the tripod too, it doesn’t do anything

Can confirm, done tests in trixion a few hours ago. I thought it was only a visual bug but was baffled when seeing no difference in damage, please smilegate fix it :slight_smile:

This update overall was overwhelmingly good, the QOL changes are insane. Keep it up !

yeah the update is absolutely fantastic, im just unsure how this bug passed through haha

thats really a bummer, i hope @Roxx can give us information when they can deliver a fix for this

It looks like 4/27 KR server balance patch has also been patched to global server. That tripod description should’ve been replaced with “Outgoing damage +30% when you have 3 gravity cores”. Try that skill with “Unnecessary Time” and you’ll see the damage difference.

I have checked this, I can post screenshots of it later if you like but it’s legit bugged, with or without the tripod at 3 cores it does exactly the same damage

Yeah, please do, because I am getting exactly 30% increase with absolute strength vs unnecessary time just fine:

No absolute strength (i.e. unnecessary time) & 3 core:

Absolute strength & 3 core:

Edit: maybe you’re comparing AS to Concussion? Concussion has 25% damage increase

I literally just re-did the tests in Trixion now and there is NO damage increase from using Absolute Strength over Unnecessary Time. The AS tripod is not working at all. Not sure where you are getting your numbers from

Then I don’t know. I’ve used 1-3-2 for the first picture and 1-2-2 for the second picture. I’ve been consistently getting 30% increase from AS.
I’ll post if it suddenly stops working, but as of now it’s working fine for me.

I did 1 and then absolute strength for one test, and then 1 and no second tripod selected and the damage was identical, it’s not a valid test if you’re doing it with a different second tripod as it’s not comparing a with and without, it’s comparing a with and then with something else

I went ahead and re-did the test the way you told me to do.

Perfect Swing: Level 7, NO second tripod selected
Average damage= ~6.7k

Perfect Swing: Level 7, AS selected
Average damage= ~8.7k

Math works out as well
8710 = 6700 * 1.3

Try restarting your client or something. I am sure it’s a bug, but I have to guess it only affects specific users, so before AGS addresses this issue, try everything you can because it is working for me and many others in the area chat.

Here is the bug in action (1 minute video). Restarted my game like 10 times between yesterday and today, nothing seems to fix it. Any idea? (i feel like i have to tag @Roxx )

1 Like

I don’t understand how it’s working for you but nobody else, I guess that’s bugs for you haha

Try Seismic Hammer’s AS tripod and see if that one works?

Yeah you were one off, it’s in patch notes to be fixed so was definitely broken

1 Like

Yeah it worked. Glad everything got sorted out