Aiming skill bug

So as today update, and doing the chaos dungeon with my sharpshooters (i play 5 of them so i dont know if this occurs with other classes that uses charge/hold animation) i noticed something weird with some skills like snipe or charged shot.

before the update when you use snipe i used to aim the skill in my back so the animation does a step towards my real objective, you hold the button skill until perfect shot area and then realease the button, and the damage goes where my mouse is currently at the moment of release.

Right now with the update, what happens is that where your mouse is at the moment or fisrt pressing the button skill, no matter where your mouse is currently at the moment of realeasing the button, my skill goes where my mouse was first pressed. ( no need to tell you how bad this is for performance PVE/PVP or what ever)

similar thing happens with charged shot, before the update the skill used to charge and then your character tries to move a little bit where your mouse is currently at, theres is even a tripod for the skill so the movement is better so you can redirect the skill to a location you want, right now with the update the same thing as snipe happens, where your mouse when you fisrt pressed the button is where your skill goes when you release it, and the character stay still not even rotates an inch if your mouse is somewhere else, i even tried the tripod i mentioned and doesn´t work.