Auto-dismantle tool isn't working as intended or could be poorly translated text

Hello, I’ve tried tweaking and playing with the auto-dismantling tool to see how it actually functions, but it seems like the tool isn’t working as the filters / text implies. I have used every possible combination/option on and off to try and figure out how it works but turns out a couple of filters work as stated but some other don’t work or is overridden by another filter which is not stated.

Just a heads up, I know the tool auto-dismantles gear upon acquiring it, I’ve been testing it days on and off, and I’ve set it for multiple item qualities. Here are the issues I ran into:

-Tool doesn’t auto-dismantle the filters applied.
-Tool end up dismantling all acquired accessories regardless of filters applied.

Have you read the yellow text? Regardless of quality & tier stuff will be dismantled if you ticked the box for Domination, Endurance or Expertise. Many people missed that, maybe that’s the issue here?

Yes I have and I had multiple occasions where I dropped those exact stats without a favorited engravings on them and not get dismantled…

The whole Auto-Dismantle feature is poorly coded. Non-tier gear doesn’t auto-dismantle. I have legendary flagged and Relic gear is for some reason auto-dismantled. Gear with the bad stats is included. Engravings not in favorites are still in inventory? I feel like it’s likely even coded backwards, or the opposite of what is intended.

idk this is exactly what it feels like