Awakening Quest was removed

My quest also disappeared at this step.

Same here pls dev help fast.

Just a heads up. I tried using Song of Trixion to go back to Beatrice and see what’s up and she gave me my first awakening skill.

How can we get a dev to help look at this? The second awakening is really important for progression and there are at least 4 other posts that sounds similar.

I can’t even get the quest to start the chain despite having done Rohendel in full.
I agree that this issue would be paramount to fix as it’s stunting character progression heavily.

Same here

Having a similar issue i had to abandon the quest now i am unable to redo the quest it shows as completed but i have do not have the skill.

2 Likes

I just finished the first part before recent server maintenance and I’ve got the 2nd part already.

Says quest is finished. last step was not complete. did not get awakening skill.

1 Like

Turned in first part of quest and now it says completed and i have no awakening skill.

I think my awakening quest is bugged. I applied a power pass on my alt, which gain awakening already, but my main character has yet to get the awakening skill, but when I went to request the quest it says its completed already but I don’t have the skill

guys i have the answer go on silentsierra u have 1 quest to take on the port take it and its good

FIXED:

Hey everyone, Placing my fix on a few posts here as it seems this is a recurring issue that has yet to be addressed.

The problem is that the quest chain can go under [Completed] after you finish a step and then stay there not providing a marker to the next spot.

Step 1: Go into your completed quest tab in your Journal under [Trixion].

Step 2: Identify what quest part you are at and then google the NPC Start location (This varies per class so im unable to reference them all) I used lostarkcodex.com to lookup the quest name.

Step 3: identify the location on the map where the NPC is and Travel that way. Once in the same area you will be able to see their quest icon on the map.

Step 4: Profit

As an example: our Sorceress friend was stuck and when we identified Mage Cerial as the NPC for the 4th awakening quest step, he traveled to Croconys Shore and boom. Finished up the chain and got his awakening skill no problem.

Please let me know if this works for everyone. It appears that the bug simply places the quest chain under completed which removes map icons.

Putting in a random line here since it wont let me spam. (Rightfully so)

Happy Ark hunting!


I canceled the task but I can’t start it again it says task complete

1 Like


Talked to Beatrice and got the quest but she didn’t give me my awakening skill nor it’s in my mail. I’ve tried all the attempts above like resetting or powerpass a new character to 50. My other character received its awakening but not my main. How else do I resolve this issue?

Guys, you have to finish all quests marked as a [journal] to get the awakening quest

Hi Folks! :wave:

Thank you for posting your concerns in our forum and, thanks to @MoistProvolone to take their time to detail a possible fix for everyone!

Regarding this issue, you can follow the steps provided by @MoistProvolone to try to fix it. Also, you can perform a Steam Game’s Files Integrity Verification and try to relaunch the game.

If after trying all these steps, you are not able to complete the quest, please reach to our customer support Contact Us | Amazon Games to file a ticket on your behalf in order to have a deeper look into your situation.

Hope this helps!

See you in Arkesia! :elf:

Thx man, actually worked.

my friend doesn’t seem to have the first awakening skill. nothing in inventory or mail. not sure what to advise him

I have tried this fix but I need to talk to Sasha in Vern to start the last quest as it is under complete. I do not have enough charisma to talk to her! I have submitted a ticket weeks ago. can we get this fixed for me please. I am item level 840 with no awakening skill