{BUG} Giant Mushroom Island

I encountered a bug that seems to pertain to my game client. When on the island, after drinking the cashew juice, when I proceed into the area, the game black screens and reloads me full size in the spot where I drank the cashew juice. This has been repeated on both characters male and female, I’ve verified the integrity of my game files and this bug still persists.


Same here, and I watched the same thing happen to a bunch of other people here. Please look at this

I have tried a fresh install, it still does not work. This is really frustrating, I just want the island soul :frowning:

1 Like

Any update on this bug? This is the logging experience farming island and it is NOT working.

same thing has happened to my character. I got the red cashew potion and head towards east of the map and yet I dont get the pop up “press G” to transform even though I used to.
Please fix

I have found this same bug, I can not reenter the island to get the soul, tried on multiple characters. Any word on this being fixed?

bump this, i have the same bug

BUMP- same bug! Any solution?

I did find a solution. Remove (if any) red cashew juice from your inventory.

  • Abandon the quest. I did this all before returning to the island.
  • Once on the island, talk to the npc with the quest and accept the quest.
  • Walk to the vender and buy a cashew juice and drink it where prompted, a cut scene should play and you should be able to walk in no problem.

I did not take any chances and I just stayed in the small state in the island and chopped down the giant mushrooms until I got the island soul.

I have not returned to the island to test out if I could enter without the quest. I guess I could test it out when I log back in and have some free time.

Sorry, but this solution only works for people who comes here and reads your suggestion, and do not complete the quest.

I believe most of us here have already completed the quest. The devs needs to FIX this bugs, as that is the only acceptable solution.

I asked about this in another thread. Did you try pressing tab after consuming your cashew juice? Apparently when you drink it it teleports you inside the zone. I kept walking out of it by mistake because the exit was right where the entrance was lol it was so embarrassing

At least you can get the cashew juice xD It doesn’t even let me buy that stuff.