Bugged quest - The End of the Chase

Hey,
I have a bugged quest called “The End of the Chase”.
I’v watched a video on Youtube showing that you need to accept the quest, then press F5 on a circle nearby.
Problem is, the F5 option doesn’t show on my options - i can see the circle located near me, but can’t press the button.
I tried to abandon the quest and retake it, but still i haven’t received the option to press the F5.

Any ideas on what can I do?

Where are you stuck exactly based on this video?

is the quest showing at the right side of screen?

have you used feiton powerpass yet? (i believe it autocompletes this quest series).

Hey,
right on the start.
notice after 15 sec, he picked up the quest and received an option to press F5 (operate the device).
I don’t receive this option.

have you tried looking for the item in inventory? At bottom l;eft corner of inventory is a button that says quest items.


I have the item needed, but cant activate it

The only thing I can think of is not having the quest actively tracked (i.e. tick the box on your screenshot of it) other than that im stumped.

1 Like