Can not get to server page

After the July 20 update I get a light blue screen before I get to the server choice page. The game loads as normal tell then.

Hello chunick.

Welcome to the Lost Ark Forums.

I really appreciate you’re communicating to us about this issue.

For this issue I want to confirm if you already applied this troubleshooting related with the Internet Protocol Version 6 (tcp/ipv6) is disable:

  1. Open Windows settings.
  2. Go to your Network&Internet section.
  3. Click Change Adapter Settings.
  4. Right-click your connection (It can be either LAN or WIFI adapter) and go to Properties.
  5. Scroll down in the menu until you found the option Internet Protocol Version 6 (TCP/IPv6)
  6. Uncheck the box next to it and restart your computer.
  7. After this process verify Steam Integrity Check files:
  1. Re-launch Lost Ark.

If you already have this troubleshooting setup, please follow and verify these as well:

Please let us know as soon as possible if after these troubleshooting the problem persists. Also, I want to request which server are you located please and your main character name as well.

Thanks for all your feedback and specially your patience. :man_mage: :small_blue_diamond:

pastedImage (3)

It worked. 48 files had to be replaced as they were not valid. Thank you

1 Like

I’m really happy to hear It worked for you chunick, Thank you so much for sharing you were able to fixed it and I wish you safe travels in Arkesia. :world_map:

pastedImage (3)