Cannot access stronghold

The song won’t work, and I’ve tried moving areas, making sure other songs work (triport, escape), re-launching the game, visiting my own stronghold through the guildmates page in my guild, visiting other strongholds (those without similar issues I am able to visit), even tried getting other people to visit my stronghold through area chat. absolutely nothing has worked, and I know I’m not the only one experiencing this. Please send help!

Server: Bergstrom

1 Like

Hello @Kiefscoop,

I’m very sorry to hear about this situation with the Stronghold.

If you haven’t try any of these basic troubleshooting steps please go ahead and try them just to discard some other factors that might be interfering:

  • Verify the integrity of the game files, steps to do it will be on this link.
  • After that please close steam and re open it as admin and launch the game.

If the problem persist after trying this steps please reach out to our live customer service, they will be more than happy to open a ticket to investigate your case.

When you get a response on your ticket please let us know!.

Apart from this have a nice day and see you in Arkersia! :leaves: :dagger:

This also did not solve the problem. verified, launched as administrator, still nothing when I play the song or try to visit my own stronghold. ticket submitted.

Understood, please let me know if you have any updates!

Lot of people on NAW Bergstrom having this problem…not something on all of our ends I don’t think

Same boat here, can not access…

Stronghold was working fine but suddenly stopped working around 20 hours ago. Play song, song complete, then nothing.

Edit: Also US West Bergstom

+1 to this issue.
Was fine for me yesterday, but today, song of escape didn’t let me leave stronghold, so I left through the teleport, had hearth and home not work once about 6 hours ago, but worked right after, and now it doesn’t work at all.
US West Bergstrom

Same issue with myself, unable to access stronghold for the last day or so

Same issue here. Also Bergstrom. Can’t get to stronghold. Worked yesterday but not today. Triport song wasn’t working either.

Also on Bergstrom and cannot enter my Stronghold.

same issue here

Also same issue here. Been about 24 hours now.

Update, I was able to enter my stronghold after work today. no response from support other than a guy telling me he forwarded my ticket on to ‘the appropriate team’ and would forward any info he had back to me. The first thing I did after the queue was play the song of hearth and home, and it worked so I guess problem solved for the time being. I can let you know if it happens again any time soon.

Stronghold suddenly started working again