Cannot buy more Royal Crystals

It has been 3 days in a row now where I cannot buy royal crystals. I keep receiving the error message “You have reached today’s purchase limit. Please try again tomorrow.”

All 3 of these days I have not purchased any crystals, so I do not know how I can hit the daily limit if I have yet to buy any. Is this error message suppose to advise of a weekly lockout instead of a daily lockout? Also what is the “limit”? Would help to track spending to prevent running into this issue.

Hello @CWS,

Thank you for taking the time to reach out to us, I’m so sorry to hear that you’re not able to buy more crystals.

Is this happening every time you try to make a purchase even with smaller purchases? Also, if you haven’t, try making smaller purchases just to test how much is your daily limit. Please let me know once you tried.

Looking forward to your response! :sunflower:

1 Like

Thank you for the response.

I have tried all the packs, smallest to largest and it will not let me purchase any of them. I receive the same error message for all options. In the past If I dropped down to the smaller packs I could usually buy them and coast my day out and I was fine the next day. This time however it’s just locked me out of all options.

Not sure if this additional info helps, usually I buy the $100 (USD) pack about every 2-4 days depending on what good Mari has to offer. Since early release it hasn’t been an issue until this week. I’ve checked with my bank, and its not on their end, checked with steam and it doesn’t appear to be on their end. So I’m not sure but it might be an in game issue.

Hey @CWS,

Thank you for replying.

In this case since you already checked with your bank and steam, the best thing to do is contact live support for them to further investigate what’s causing this in your game, if needed our agents will escalate the issue to our devs.

Hope this helps! :sunflower:

1 Like

I contacted AGS support. I was advised its a known issue and is being worked on, however the rep said he didn’t have much information on it that he could share with me. So I will try to make a purchase latter in the evening and I’ll report back here in case this helps anyone with a rough time frame.

@aePixie thank you very much for the assist. Hope ya have a nice day

Thank you for letting me know,

Please keep trying, if anything, once we have more information I’ll share it with you on this thread.

Have a wonderful day! :heavy_heart_exclamation:

1 Like

Update : for the 1400 hour bock Mari shop, I was able to select a package to purchase, however now I am just receiving the error message “Purchase Failed”. So I’m past the daily limit, but now it won’t le me purchase the $100 pack. On the positive though, I am able to purchase the $50 pack. So maybe the issue is with the $100 pack? I did have enough money in my Steam Wallet for the $100 so it wasn’t that. Hope this helps. Will check back again after a couple days and re-attempt the $100 pack.

Update : After reaching back out to Steam, it turns out this was on Steams end. So just to keep tracking good:
1st interaction - was advised it was an in game issue and not a steam issue by the steam staff.

2nd interaction - was advised steam flagged my account as suspicious after over a month of transactions. took them about 24hrs after contact was made to verify and reverse the issue.

I was still getting the “Transaction Failed” message in game and not on the steam page when trying to purchase. This lead to the confusion / assumption this was an In Game issue instead of a Steam issue initially on my end. Not sure if this feed back can help y’all in the future @aePixie .

Before this thread is ended, if there is anything else I can try to provide on this matter to assist with, please let me know. I would also like to thank you again for the help and support, and wish you and the rest of your team a good day and well wishes.

I just wanted to bump this thread for visibility and let @aePixie that this seems to have been the solution to my issue (I made a thread yesterday). While I was able to add funds to my Steam wallet, I was getting a purchase failed error. This led me to believe that the problem was with Lost Ark. However, after seeing this thread and contacting Steam support, it turns out that my account had also been somehow silently flagged (despite having no issues and receiving no notice). It took about half a day after opening a Steam support ticket and referencing the information here for them to fix the issue.

Thank you @CWS for updating your thread and providing the solution!

1 Like

Hello @beltanii @CWS,

Thank you for replying and sharing the updates on your situation,

I’m glad to hear that you were able to solve this issue with steam, thank you for sharing this as this can be very helpful to other player that may encounter an issue like this.

Have a wonderful day! :sunflower:

1 Like