Cannot buy Royal Crystal

Would love some help with this issue, trying to buy the 100€ crystal pack but can’t.
I’ve checked file integrity, don’t know what else to try.

Thanks in advance.

Hello, @jovilife.

Welcome to the Lost Ark Forums.
We hope you have a great time here in the community.

I am sorry to know about the purchase issue that you are facing.

A Purchase Failed message, of course occurs when there’s an error processing a purchase request. Below are the possible reasons and how to troubleshoot Purchase Failed Error Messages:

Check Steam Overlay

When turned off, your in-game Steam Overlay causes your micro-transaction purchases to fail. To turn on the Steam Overlay:

  1. Go to Steam on the top hotbar.
  2. Select Settings.
  3. Select the In-Game tab, and then turn on Enable Steam Overlay while in-game.

To learn more about Steam Overlay, check out Steam Support :: Steam Community Overlay.

If your purchase was cancelled or service was interrupted

Purchases within the in-game store require you to confirm your selection before completion. This error message may appear if:

  1. You cancel the purchase before it completes.
  2. You experience any kind of service interruption during the purchase proces.

If you’ve reached the purchase limit for this product

There’s a limit to the number of times that you can purchase some in-game store products. Some examples of these limits are weekly purchase limit, and single, one-time only purchases. If you try to make a purchase that falls outside these limits, you’ll get the error message.

Please do check this and if this is un-relatable to your case, then I recommend you to kindly reach out to our Live Chat Support for further assistance, our colleagues on that channel will be able to raise ticket for you. if required.

We hope this helps.
Thank you for understanding!

Greetings again,

So steam overlay should be fine, I’m getting this Fail to Purchase message after I press “Authorize” on the steam overlay window. I tried multiple times, doubt it would be any kind of service interruption. I tried the 50€ pack and the purchase went through so I’ll consider it solved for now.