Cannot log into character

Server: Elzowin
Character Name: Kyanis

Tried to go to Borea’s Domain to finish the Stronghold potion quest. Game just crashes. I can play other characters fine though.

Sent in a support ticket a couple hours ago, but never heard back. Not even a bot message confirming my ticket was received and would be looked into as soon as possible. That just seems sloppy.

Read another post of someone having this issue. They fixed it by validating steam files. This also worked for me.

1 Like

Hello, @zenzic Welcome to our forum community!

I can see you were not able to log into your character. Thank you for submitting a support ticket earlier and for sharing character details as well. Also, we’re sorry for the problem this has caused to your game time, and at the same time, I’m glad to know Lost Ark’s been working after validating steam files. If you encounter issues in the future, feel free to reach out to us via forum as well.

I hope you can enjoy your instance in Arkesia! :hugs: