Can't access Phantom Palace Hard Mode secret

I’ve tried to many iterations with multiplate tactics and I can’t get the “light” buff that all the streamers seem to get with ease on a single loot.

I’ve tied it pre and post boss death with and without stealth and it doesn’t resolve.

What’s going on with this?
Is Mokoko collection supposed to be this complicated/involved?

I have a similar issue… I can get the buff however i cant access the option to use it on the right side pedistal only on the left. which only completes 50% of it… and i have done this dungeon 20 times now trying to get the last mokoko seed in it…

1 Like

Buff disapears when used on the left first but cant access the right even before this happens

Watch this

yeah i cant put it in the right side to begin with… it wont let me

Any news about it? I’ve just tried to get it and can’t interact with right butterflies. Is it a bug with interacting or did I do something wrong?

i was stuck with this too but going in to matchmaking with 4 ppl solved it. at least thats what i think how its solved.

Watch the video, Make sure that you are getting the secret thing with the mini boss within a minute of starting the mini boss not after killing the mini boss. The golem I think it was. Has to be right as the fight starts. Then when it is the butterflies grab the right first and then the left somehow that worked for me. I think going with a group is better to make sure that more people get that thing in the boss area the “light” and then two people at once can do the butterflies.

It appears that the rook buff cannot be obtained solo, you must be a group in order to get this buff. Kind of silly because everytime i try to complete this the rook is dead before the buff can be obtained

I did it solo

Circle the edge to figure out where it is first then lure boss to complete other side and run back to buff using a stealth robe to dig.

It took me a few tries because it was unlucky when he started to summon chess pieces on me for w.e reason. I tried some times with scarecrow as well because people suggested it to work and it literally didn’t taunt worth of sht. It would reset after one taunt and then would do some widespread aoe canceling my dig

I just used three stealth robes bar completed but it never gave the buff

it has to be within the first minute of boss start so timing is extremely crucial

It was, i will go through it with my main and see if it will work solo

Unless something with the most recent patch blocked it…i did it sometime last week before maint and got it even though i nearly broke my keyboard


In order to get the first buff you need to be on hard mode and it has to be done within the first minute of the boss fight (this is as far as I read and it worked for me - solo mode 30 min before this post).

Many thanks to Jmez, Leixa, and Raiylu (from Azena, and not sure which other servers) for matchmaking today and helping to achieve this secret mokoko and gain the achievement!! :smiley:

Toggleblade (Ladon)