Can't access Stronghold

I can’t access Stronghold through the song, it plays and just ends… Not sure if connected, but I can’t even board my ship at any port, or teleport there via song…

Edit: Boarding the ship works now out of nowhere, but still cant use the song to reach Stronghold


Yeah. I am having this problem too. Can’t access my stronghold by playing the Song.

1 Like

I thought it was just me and I cannot access my stronghold either

1 Like

I couldn’t access it as well. I tried reloading steam and the game as well as reselecting my character just to find myself in the same situation.

1 Like

I posted this same thing over 3 hours ago. No one can access my stronghold. not even my friends. I can go there’s but not mine.

1 Like

I hope they fix this because it’s actually really annoying

1 Like

Having the same problem, on Mari server :frowning:

same issue, also mari. can’t even claim my finished knowledge transfer…

Also Stuck in Mari unable to access stronghold, appears several other areas are also unable to triport to.

I created a web account because that where they say to report bugs and then i can’t report any bugs. I can’t reach my stronghold either and I’d like to report a bug!

Same problem on mari. Character pck

Same here since afternoon yesterday:
Server: Mari
Character: Shinasura

I can no longer access my stronghold on Mari either, starting today. I tried reloading the game. Song to travel to stronghold was working fine yesterday!

Also on Mari. Also started happening last night.

Also on Mari. Could access it for most of the yesterday, and then around 10pm I couldn’t access it. I can access guildmates’ stronghold, but nobody can access mine.