Cant actually close the game

Basically as the title says cant actually close the game tried alt f4 pressign the quit button etc. Even task manager cant close the game the only thing that works is hard killing the psu on my PC

This issue is currently being monitored on this thread below.

The “Can’t close game” and “CPU usage is high” issues are directly related.

To elaborate on this:

  • If I open Lost Ark now: CPU usage is normal and can close the game as usual.
  • If I open Lost Ark and wait 20-30 min: 1 CPU Core is at 100% and cannot close the game.

So whatever is causing the game closing issue is also causing the CPU usage issue, or vice versa.

Hopefully gets fixed soon.

Thanks for letting us know about this.

I’ve had this happen 3 times now. I’ve ended task on Lost Ark, EAC, and all things Steam.

Restart Steam and it still shows the game as running.

There’s got to be some other process that’s running, but I can’t, for the life of me, figure out what it might be.

The only way I’ve been able to resolve it is by restarting my computer.

I had it happen once after the game did the whole disconnect to character screen thing. Then the other two times were when I was at the character select screen, had to be afk for a while, then tried to log back in and it crashed out with an EAC error.

Did you try the EAC repair fix they issued a couple of days ago? Should fix the issue for you if you didn’t.

Nope, doesn’t fix it. I don’t know what’s still running, but Steam sure thinks it is.

Only thing I can think of is to make sure you do the repair as admin, otherwise I’m not sure. That fixed it for everyone I know.

It’s not an every time thing. It’s happened just enough to be annoying though.

Yeah mine was the same way until I followed the steps for the fix they released a couple of days ago, same with my buddies. Hope you fix it.