Cant buy gems. "purchase failed"

Tried restarting the game etc. Anyone else?

Having the same problem, the steam purchase page doesn’t load up.

have to turn on the steam overlay for the game then restart the game
Screenshot_2

Not an offical answer i guess but i have had the same issues in the past between my account and my girlfriends acccount.

3 possible reasons:

  1. Steam semi locked you purchase limit. You need to open the payment query option in steam to unlock this. They will ask for your card details etc. (not full. Just last 4 digits etc)

  2. You have hit your purchase limit in Lost Ark for the week/day.

  3. Purchase bug. Sometimes i could not buy the 100$ package but can only buy the 30$ one. If this is the case, or similar, then you have to inform the lost ark team as this is their bug.

1 Like

Hello @Slackware and @Seph .

If you’re having issues with the royal crystals, what @Drudia and @Guccibae mentioned are some of the common issues, here is the troubleshooting for the most common issues while purchasing trough the store:

If you’re still having issues you can also check on this page for other common issues with purchasing from steam:

If what you meant is Gems in the Auction house it could be related to the account’s trusted status not being active, if you meet the conditions for the steam account to be trusted (It can take a couple of days for Steam to validate an account as trusted) or the troubleshooting above didn’t fix your issue I would recommend you to contact us directly so we can investigate further:

Let me know if you have any questions!

Sorry about “gems” being confusing. Royal crystals are what I was referring to. I’ve purchased before, not in the past ~month so no issues with limit. I’ll try as recommended.

1 Like

This worked, however I had to go to Steam at the top, settings, then enable there within the non game specific settings. It wouldn’t allow me to enable for only Lost Ark.

No idea how these settings got changed. I’ve never been in there before.

2 Likes

glad everything got sorted, it is likely a steam bug that turned it off

Happy gaming