Cant connect to servers

iv spent more than a day to try and fix it on my own to see if it was on my end but to no success
every time I try and join a server i get the same error code w0x5-spelpwp1n2nt i can get all the way into making a character but when i try and finalize it the error pups up
iv tried the following to fix it:
Verify the integrity of the game files
Reinstalled the game twice
Removed any and all vpn’s from my pc
Tried disabling my firewall and virus protection
Restated my router
Reset my router
Flushed my dns (even though there was nothing wrong going on there in the first place)
Tested my network and its 100% stable with a solid 100/100 connection (5ping)
I only run on a wired connection so no instability on that front
And last iv tried connecting to every single server but with no luck (i did check if they where up in the first place and they where)
If there is something iv overlooked pls let me know all i know right now is despite everything it isn’t working and i really want to try the game but at this point it feels like more effort that its worth