Can't dismantle old gear without switching presets first

Perhaps I haven’t noticed this before, but this is pretty annoying. Every time I replace gear - mostly ear/neck/rings - and want to dismantle the now no longer in use gear I get the message that it’s part of a preset and I have to save my new preset first before I can dismantle this piece. Why? Why can’t I just dismantle gear without having to save my new gear to my preset first? Is there a way to disable/change this, is there an easy way to save a preset instead of having to actually switch to a second preset and then change back?

I realize this is a minor gripe compared to a lot of other problems that are going on, but it’s still something I would like to see resolved.

29 Likes

I’m finding this super annoying, too.

9 Likes

It is very annoying and I have no idea of what the point of them changing that was at all, does not make a whole lot of sense to me.

4 Likes

Yup- this is annoying. My paladin is 1302 and is in the process of finding higher quality blue gear from cd. So I would equip the newly dropped higher quality items and dismantle old ones. It wasn’t a problem until this new update.

3 Likes


if i’m not wrong,you can just rename the preset instead of switching to a 2nd one

8 Likes

Hm, okay, that does save a bit of time, but it’s not the most elegant solution. Thanks for this in any case, it does eliminate some excessive clicking!

3 Likes

Yea it’s kind of annoying but you don’t even have to rename it. Just click the edit button and click ok. It won’t be that big of a deal when you’re rarely swapping new pieces in and out. IE 1415+. It’s just annoying when pushing alts, but it could be a useful feature in the future I guess.

1 Like

took me some time to even figure that out, or should I say my wife found this out lol

This is NOT a MINOR gripe - not you have to play around and fiddle with buttons - if you don’t want to mistakenly destroy something then just lock it - it is so annoying not to just select and destroy! I vote NO to this ‘improvement’ which is a BIG hassle.

5 Likes

Bump. Definitely annoying to have to save presets in order to dismantle swapped gear.

2 Likes

Here’s a fun thing I noticed, switching zones and sometimes going in and out of dungeons will “unlock” the preset stuff that is in your inventory, allowing you to dismantle. It doesn’t always work for dungeons, but has always worked when jumping between zones…no idea why that works.

I’ve only messed with this while leveling up Destroyer up to lvl 25 so far, but can only assume that this is another workaround you can use for this problem.

For sure it’s annoying as heck.

2 Likes

Yes This sucks ass!!!

3 Likes

This has been a thing before the patch. I couldnt sell gems because they were apart of my preset. Just change the preset…

Same people saying “idk why this is a thing” would be the first ones on the fourm to complain they accidentally sold/dismantled their gear… lol

Please find a way to fix this, this is extremely vexing.

A popup showing when clicking dismantle and stating that gear used in presets is about to be dismantle and if we’re sure to proceed with the dismantling would be an extra step than what we had but much less irritating than the preset switch we have to do now.

Never hit this problem till now, and being quite new and low level, I’m constantly switching out gear to better stuff and this is really putting me off!!! What a crap improvement

1 Like

I find it interesting that you can discard the item but not dismantle it.

Also, if you just switch your gear preset (not the entire “full” preset, just the gear portion of it), apply, and switch back, it unmarks the “offending” piece. But yes, please just let us dismantle the stuff.

This is a complete fail of a change. The old system was fine, and it worked. This system is total garbage. Not to mention the Up Arrow noting gem upgrades is now gone, not earth shattering but why remove an actual useful thing and then add this terrible Dismantle change?

3 Likes

I wouldn’t even mind the way they deal with this when fusing gems that are part of a preset: When you right-click a gem to add it to the fuse system you get a pop-up saying that it’s part of a preset and then you can manually add it to the fuse system, which negates the fact that it’s part of a preset. Just have a pop-up appear when you press the dismantle button saying ‘are you sure, because item x is part of a preset?’. That way people are less likely to accidentally dismantle gear they want to keep and it does away with the whole having to perform an extra action to dismantle stuff.

Also, it doesn’t matter whether or not you swap gear for better pieces often or rarely; it shouldn’t be a hassle when it’s part of the regular gameplay.

Found a quicker way to get around this preset issue.

Just rename the preset tab and save it. You don’t even have to change the name, just click on the rename button and save it as is. It’s worked every time for me.

Still annoying to deal with, but it’s much less maddening and time consuming than some of the other things I’ve tried (changing zones, in and out of stronghold, etc)

2 Likes

This is super annoying. Needs fixed asap.

2 Likes