Can't get on my destroyer

Hi, whenever i try to get into my destroyer, the loading screen gets slowly to 25% and then the game auto quits. I tried a couple of times to get inside but same thing everytime.
I’m on zinnervale and my destroyer name is : Titandestroyer.

2 Likes

Hi @Titan3122.

Hope you’re great :sunny:

I’m sorry you’re getting this error with the screen and that Lost Ark quits, in this case I’m going to relocate your character to check if that works and you can go back to play, please be offline in order to relocate your character.

I’m going to update this post as soon as I relocate your character.

Meanwhile please Steam Support :: Verify Integrity of Game Files

Edit: I relocte the character can you check if did it work?

Thank you in advance :raised_hands:

Hi, still not working.
Attaching a SS.


It stopped there and the game just closes on its own…

I verifyed the game files. 3 files couldnt if i remember correctly and it said they will be replaced(?).
This morning i tried again getting on my destroyer and the game auto closed without trying to load into the game.

1 Like

Hi again @Titan3122.

I’m sorry for the late reply, thanks for this important information, if the game closed, to make sure everything is up to date, when you hjave a chance please try this if you didn’t do it yet:

If the issue persist we like to take a closer look into this issue with you, when you have a chance, please use the link here to speak with our Customer Service team:

Contact Us | Amazon Games

Please make sure to have the DxDiag ready once you reach support, you can pull it following this steps:

DxDiag report:

Go to Windows Start search bar and type dxdiag.

Click on dxdiag.exe.

When green progress bar goes away, select Save All Information and save the file to their desktop.

Also please make sure you send this link to the agent so we can help you to investigate this issue, also give them all the information needed. And please let me know how was it!

Cheers! :sunny:

1 Like

I verified the game files a couple of times again and now it works lol
dunno how but thank you !

1 Like