Cant log on with my character

Was freezing as loading character or very soon after… i was able to teleport somewhere fast enough but it frooze in the middle of doing that… It said i was at the different place but still fails to load my character… Can someone help me… I Just did the verify game files and it did say 2 files were bad and replaced, but still freezes during loading my character.

Character: Cannabinoid
Realm: US East
Server: Karta

Hello @mellow311

Apologize about this unexpected situation where your character got stuck I would love to help here!
We can try to teleport your character to a safe area in order to avoid the glitch!

Cheers!

Originally got stuck at Wildwater Island… but i managed to use one of my teleports fast enough to Nia Village but game frooze in middle of teleport… At logon screen it says my character at Nia Village now… but freezes during loading

Hey @mellow311

I just ported your character to a neutral location hope this can help to unstuck your char.
Let me know if you encounter any other issue!

Keep gaming hero!

The port worked but the game still doesnt load after selecting my character and clicking launch… Just to try to see if it worked I tried to make a new character and the game also frooze when loading to make a new character… Dont know what happen… Game was working completely fine yesterday.

Hello @mellow311

Apologize about this situation I understand it can be frustrating not being able to log in the game.
I have some troubleshooting steps to follow in order to find a fix on your issue:

  1. Please verify the integrity of game with the Steam integrity check

  2. Update your video and windows drivers.

  3. Restart Steam client.

If this dont give you any possible solution I would suggest to contact live support channels in order to create a ticket for your specific case.

Cheers hero!

Yeah… tried all that… Still not working… Whats wierd though… Now today when I try… It now freezes when I click a server to connect to. Cant even get to the character selection screen now… All other games on my pc working fine. Seems to be getting worst now

Im wondering if this has something to do with the EAC thing… Allthough i get no error messages about EAC … Only the game locking up entirely while going to the character selection screen or sometimes when I am able to click launch to load the character and it locks up right at the begging of loading the character in the game… I have to end task it eventually

Can you maybe re-move my character again to a safe spot. I am still unable to play at all for days now.

Hello @mellow311

I have relocated the character back to Prideholme. Please verify the integrity of the game files on Steam Client before relaunching the game and check if you are able to access it now.

I request you to contact the Live Support if the issue still persists so that we can create a ticket for the particular issue.

Have a great rest of your day. :slightly_smiling_face:

Well at first it didnt work again… But then I went back in and looked at the settings of the game and noticed under the video settings my texture quality was blanked out… It was set to nothing which you cant normal do… So i set it to a setting and now IT IS WORKING AGAIN…
So that seems to have fixed it.

I noticed there was a post also about this setting not getting saved also and it blanking out for other people too, but they were still able to log on… So not sure whats going on… but this seems to have worked for me for now.

Hey @mellow311

Thank you so much for sharing this information I would definitely use it in future cases and I am very happpy that your issues was solved.
Related to the EAC errors this information can help to troubleshoot that specific feature.

Keep gaming hero!