Can't open market place

I can’t open the market place, whenever I try to open it, it says “The Market Placer is under maintenance”. I’ve had friends tell me it’s working fine for them so I’m assuming there isn’t really a maintenance going on. First had this problem before going to bed and when I came back I’ve already restarted the game 3 times without results. Image of what happens below. Server is South Americas’ Kazeros.

3 Likes

same problem here been trying now for 3 hours , its not working

EU : Wei

Same problem here. Store can’t be opened and also the item box (e.g. founder items) are empty :frowning:
EU: Asta

Seems to be working now

Having this issue on Aldebaran. Cannot access founder/DLC rewards as a result since swapping servers with friends. Unable to open Market all day.

Hello, Everybody and sorry for the late response on this one!

Devs are working to have this solved and you should be able to open the in-game store by now, regardless it could take a bit more of time for other players.

Please keep me posted on this one!

1 Like

same

East NA : Aldebaran

3 Likes

Still unable to open Market Place / Lost Ark Store on East NA: Aldebaran at this time.

Product Inventory comes up with "Communication error with the billing server. (failure_191004 : invalid purchase number)

2 Likes

let’s give it a bit more of time, you’ll be able to access the store in a bit more. We apologize for any inconvenient. Make sure you check this post for updates.

I’m able to open store and recieve items from product inventory on Sceptrum.

But I’m unable to do it on Nineveh, store and product Inventory still not working in that server.

1 Like

Having the same problem on Slen for over 5 hours now, I’ve seen repeated posts where we are told to wait, people suggesting to try different channels or even relogging and so far nothing. No aura, no shop, no products.
I understand its a complex issue but having no idea of when the products I paid 100 euros for might come back is scary.

Thank you I’ll let my friends know also as they are wondering where their founders packs are.

Bother servers are on EU.

1 Like

Same

Server: Aldebaran - NA East

1 Like

I can’t open the store in EU-Slen and all my items from the product inventory are gone.

Have the same issue on EU - Inanna where I want to play because my friends are there. But my wife playing on a PC in the same room as me has no issues accessing the store. So I have no idea what’s causing that.

I’ll add some input here. I originally started playing on Karta with the early access no issues. I created a couple characters on Aldebaran this morning to join with some friends who had joined f2p.


Got the same message as a lot of people. Tried to find my twitch drops and they were nowhere to be seen. Signed back in on Karta the store worked and my drops were there, as expected. So I exited back out to Aldebaran and the two drops were in my product inventory, but I got these messages opening the inventory and trying to redeem the drops.


Also my Crystalline Aura benefits aren’t available on Aldebaran either. Even still at this moment.

Still not working for me either.

NA East - Aldebaran

1 Like

Same for me.

EU - Asta

I can’t open the store in EU-Inanna, I can´t take drops from twitch

NA East - Aldebaran

Still not working on this server.

1 Like