Cant select one of my 2 Powerpasses

Hi,
I checked google and I tried to find a solution in here… but… havent.

My main is 1349.16. I wanted to create a Lancer today and boost it via Powerpass to 50. Thats for the plan. Reality is, I have 2 Power Passes (Vern / Feiton), the info above the Char-Name that a Powerpass is available but if I click on the Powerpass button, I cant select it PLUS I’m getting the info-text “No Powerpass available”…

Ive already switched Server, created a new char there and tried it. No change. I went back to boost my Lancer. Nope.

Any usefull tipp is appreciated…

Are u use your powerpasses from inventory ? if u dont use it , the powerpass dont appear to use from char selection screen

1 Like

You have to claim the powerpasses from your mail first , and after that you gotta use them from the inventory. After that , they should work.

1 Like

Greetings adventures!

Correct,

@derteki Try what @Hefewairzz suggested, then let us now whether you were able to use the powerpass or not

Persistence is key, regards,

:spades: JWarlock :diamond_shape_with_a_dot_inside:

Thanks for your feedback! Yeah… I havent used them ingame on my main. Done, worked, nice!