Character bugged, started deletion process

Hello, posting for a buddy of mine because he can’t figure out what’s going on. His game force closed for whatever reason and when he logged back on his character was in the “Deletion In Progress”. He tried clicking cancel multiple times, relogging, refreshing and restarting his computer to no avail. When he clicks “Cancel Character Deletion” It just stays grey and doesn’t allow him to interact with it. He’s new to the game and this is really frustrating him. I’ve tried to look around online to find a solution but wasn’t able to. Please help!

Hi there, this landed in the German localization feedback so I’m moving you over to the English Bugs. However, from my understanding, this might be a support issue. Your friend can create a support ticket here: Lost Ark - Support | Amazon Games

Thank you for re routing this! First time on the forums, typically I’m able to find a relatively good fix for things/issues I have. But this was a new one for me and I couldn’t find the answer haha so I appreciate your time and consideration. I’ll submit this to him and anybody else if they have the issue in the future.