Character stuck at Bellion Ruins

Hi my sorc on Sasha NAE, Zettairyouikii is stuck at bellions ruins and I can’t login. It crashes at around 10% loading screen.

Hello and welcome to the community!

I’m sorry this is happening. I am going to move your post over to our Game Support section so we can better assist you! :slight_smile:

Hello @zettairyouikii welcome to the forums traveler !

We are happy to have you here. I am sorry to hear you character is stuck, I will be trying to relocate the character in a moment to see if that helps, so please make sure to completely close the game please, also once you get back on the game, just before that please try running a:

I will update in a moment. Work in progress … :hourglass_flowing_sand:

[UPDATE] Please let me know once you are offline so I can proceed, thank you :slight_smile:

I am offline

@zettairyouikii awesome, so I just tried relocating your character, let me know if it works also just before starting the game run a Steam Intengrity Check I will be waiting :slight_smile:

thanks, it works!!!

1 Like

Hi… So it seems like it happened again, its due to this bifrost I have at bellion ruins. can you please move my sorc again? its the same name, zettairyouikii on Sasha NAE.

You will need to make another post on this issue. Once it’s been soft they never check the same ticket again

Hello @zettairyouikii

I hope you are doing well.

Could you please log out of the game while I try to relocate the character for you?

Please let me know once it’s done. :slightly_smiling_face:


Edit : I checked and found out that you have logged out of the game.

The character has been relocated back to Prideholme. Please verify the integrity of the game files on Steam Client before relaunching the game and check if you are able to access it now.

Have a great day ahead. :innocent:

THX IT WORKED. I will change the bifrost. I think theres a serious bug with bellions ruin

2 Likes