Constant crash on instance loading

Since today’s patch (21/04 Glavier patch) loading any instance (guardian raid/abyss) results in the game crashing mid loading.

Painful UX.

Checked file integrity x 2.
Restarted PC x 2.

Seems like they rolled out the patch WITH a « critical error » (wink wink) because of all the pitchforks and torches.


Seconded, my game has crashed twice in the past hour every time I queue up for an instance, Abyssals and guardians

2 times now guardian raid loading crash my game out to desktop

here too, at least no entrance counter is used for that… but it needs a fix

Game Crashed today atleast 10 times. Never Crashed before.

happened to my for the event raid now

Same problem, came here to see if it was just me or was common issue

same for chaos i just tried booted back to desktop

I can confirm that. In 900 hours it never crashed even once. But since todays patch, its impossible to play instances, since it crashes EVERYTIME during loading screen. Needs Hotfix ASAP!!!

first time I have CTD with this game, our whole team crashed trying to enter event guardian raid, anther person was crashing on chaos dungeons

This is especially a problem on guardian raids, everyones getting into game with 5 minutes missing due to the clients load time. My 4th member just arrived at the 10 minute mark and it’s not even their fault.

Yep everytime the queue pops and you accept it, the game crashes


I’ve also had the same issue, keep crashing when trying to load into chaos dungeons or guardian raids. Seems a bit inconsistent, happens a couple of times in a row, then they work fine and then back to crashing again.

Also some of the notices stays on your screen and doesn’t go away for an example i gained 1490 roster xp and 2 charisma and this notice stayed there until my game crash out in a loading screen.

Same, I crashed 4 times already, 3 on guardian raid event and one on chaos dungeon

same error loading boss event. the game crash

Yep aslso crashing on guardian raid