[CRASH] Ealyn “Time To Heal” Rapport Quest

  • Character name: Ambrisiah
  • Problem that occurred: Crash
  • Time and date: multiple times at 1:00am CET on march 20
  • World/Server: EU Central - Calvassus
  • Location where the problem occurred: Adventurer’s Guild, Rania Village, North Vern
  • Any action that may be taken to reproduce the problem: I started to experience the crash upon progressing through Ealyn’s Rapport quest chain “Time To Heal”, she is at Friendly Rank 2. I had just spoken to Gideon, then moved into the adjacent room to use my “F5” key to progress the quest in a mini snenario/dungeon. I then experienced a hard crash and computer freeze. The only way to get back to a normal operating environment was to sign out of Windows (via control+alt+delete) and then sign back in. I then booted up Lost Ark and then immediately experienced the same crash during the load screen. I tried this 2 more times and on another computer and received the crash each time.

Hope you can unlock my character fast and thank you for your time!

Well I guess I didn’t get unlocked fast, so I can’t play my main right now and will lose chaos dungeon & dailies for the day I guess…

Contact Amazon Game Support for help with this (The live chat) they are aware of this bug and are working on a fix but if you chat with them through live support they can send you to the closest city.

They did this for me and I was back on within 10 minutes of the bug occuring.


Well you got lucky. Experience may vary.

I also went through live support. The first thing they asked is if i was talking about lost ark or new world despite going through lost ark support and it being in the first message.

then they asked me to verify steam after linking others having the same issue.

then he agreed to “lodge a ticket”. it’s only been 90mins since it was lodged but “10mins” is probably not the norm.

hopefully it gets unlocked sometime in the next 18hrs when i wasnt going to be playing anyway.

Same issue here. Now I am waiting until the support teleports my character to another location. Anyway, I hope that Smilegate/Amazon will fix this bug asap.

I used the link from XsSlayeR3 and they TPed me in 5 min. Might want to recontact them if it hasn’t been done rapidly. The person I got on chat told me they were working on a hotfix, but I don’t know if this was true or not.

I got stuck too, and contact the support via XsSlayeR3’s link and got tp to Prideholme. Whole thing take less than 15 min.

i contacted them again the next day after nothing was done.

second guy i got fixed it in under 10mins.

Yeah, may depends on which rep you get, if they know it’s a known bug or not. Maybe directly ask for a TP to nearest city to speed up the process.

Do we know if this fix yet? I’m at the point that I need to do the quest to progress the rapport progression.

Just tried to do it and still bugged, stuck like 3 times

1 Like

Until you see something in the patch notes about this quest, I recommend not risking it.

Yes, this quest just sends you to a forever loading screen once you use the blue crystal that takes you to Ancient Elveria. Stuck twice attempting this quest, support was able to return my toon to Prideholm, not attempting a third time, xD. Highly recommend not attempting this quest until they have a fix due to risking your toon being locked and unplayable.