Direct x 11 makes me crash

this has been a thing for me since launch, everytime i was playing in direct x 11 i was crashing and i switched to direct x 9 and everything went perfect, now that the game only works on direct x 11 i almost can’t play the game anymore, i get random crashes in raids and can happen anytime.
I tried everything possible in the internet, even sent a message to support and they can’t find the problem any idea for those that had this problem ?

I’ve moved this over to the support section.

1 Like

Hello there @vladfrantza,

I’m sorry to hear that you are having issues with performance while using Direct x11, I can see that you mention that you have tried a lot of troubleshooting already, my recommendation would be that if you have already tried all the steps listed here Troubleshooting Frame Rate and Performance Issues - Support | Amazon Games, then the best action would be to follow up on the ticket you sent support, as they can investigate the issue for you.

Please keep me updated on your ticket’s progress and I will keep an eye out for anything I can find relevant to this topic.


what GPU and drivers are you using?

what exactly your PC spec

my gpu is an AMD Radeon RX 6700 XT

this is the error i get

Échec de l’initialisation de l’inscription du certificat SCEP pour WORKGROUP\TIBI$ via :

GetCACaps: Not Found
{“Message”:“The authority "" does not exist.”}
HTTP/1.1 404 Not Found
Date: Thu, 16 Mar 2023 12:19:21 GMT
Content-Length: 121
Content-Type: application/json; charset=utf-8
X-Content-Type-Options: nosniff
Strict-Transport-Security: max-age=31536000;includeSubDomains
x-ms-request-id: f38cac15-f8ea-4fc8-80b7-396540892ee7

Méthode : GET(140ms)
Étape : GetCACaps
Non trouvé (404). 0x80190194 (-2145844844 HTTP_E_STATUS_NOT_FOUND)

Had the same issue, the SCEP error is not crashing your PC, it’s just happening when you restart your PC, we fixed the issue by updating to 23.3.1 drivers, if you are not on latest drivers try them:

crashes were happening because something was up with amd directx 11 from 22.6 to 22.11. drivers (22.5.1 was stable and now 23.x.x are stable)

this is the thread about game crashing on amd drivers: Newer AMD Drivers Freeze Lost Ark - #162 by notPaladinMain

thanks i’m gonna try that and tell you if it worked

1 Like

I have the exact same issue. after updating the game is not playable anymore. tried everything. I’m about to give up on the game . these are my specs. only thing that worked out was the direct x9 option. Now its gone all went downhill

I have the same problem. My “NVIDIA GeForce GT230” was working fine with the DirectX9 but when updating I can no longer enter the game, it closes with an error after the launcher. It’s okay to upgrade but in my case I bought a 60-day aura that I’m now wasting because I’ve not been able to play for 3 days. You should consider putting the DirectX9 option again because there are many of us who were playing like this.

hello man i want to thank you with his update the crash stopped and i can now enjoy the game, for the people reading it i have done what chaudz said

1 Like