EAC driver rolled back

AGS you know what’s next right?
Fix your broken server.

1 Like

I guess the answer is fix it yourself lol


Was just about to write that myself.

And people still have the audactity to defend AGS and blame Smilegate…

EDIT: my favourite part of that official “statement” is the word “recent”. Implying it hasn’t been a problem since February.


Where did you get that info?

If a bunch of you could try this before I do, I just want to know what the fix breaks before I do it myself. Thanks friends.


The news itself is such a lie. There was no file changes since last patch nothing was changed. They fail to admit and adress the issue on their end but tell users to repair EAC when literally nothing has been changed lol.

Either they plan on actually pushing new files on wednesday or this whole news is just another blatant lie and cover up.


I agree, tried it too multiple times. Does not fix anything.

so, does it fix the core 1 at 100% usage problems?

It’s not like that bro.
Everytime you launch a EAC game it will auto download the driver from update server.
What you need to do is:
1.reboot to unload the kernel mode driver
2.repair EAC - auto remove the old .sys
3.launch game - auto download the new one

check your EAC driver’s signiture time.
It’s at C:\Program Files (x86)\EasyAntiCheat\EasyAntiCheat.sys
If it’s Nov. 28th = buggy
Oct. 21st = rolled back

yeah same for me, except it uses the correct time format :wink:

I got free pheons after doing the fix they suggested

1 Like

if system process still cost a lot of CPU usage that’s no fixed.
otherwise maybe not EAC this time

okay, looks like the second core 100% usage stuck problem have been fixed. my 2nd core is working at normal usage now while the game is running and closed


1 Like

previously it’s like this : Game not closing after gpu driver update - #7 by ChinGG

only 1 of many cores is at 100% the others is at normal usage percentage levels. and it stucks like that even after the game is closed

Thank you for this.

tried logging on another character after the fix boom game just closed itself without error, nice…

While ingame its working (for now) have the 21st oct eac digital signature, core 1 is no longer being kidnapped and “system” process usage doesnt go over 1%, haven’t tested quitting the game but so far “works”?

Me too. I used to just dc but now I get stuck in loading until I drop….it started after the last update for me.