Endless loading screen Ealyn rapport - Ancient Elveria

Well it seems like I got stuck in the endless loading screen that is " Ancient Elveria " with the rapport quest of Ealyn, i’ve looked at the forums and it seems to be ongoing with a lot of other players, I tried to ask support but that didnt yield any help, and I got told only developers have such powers? All I asked for was a teleport out of the endless loop…

So here I am, asking yet again - Please just teleport my character out of the endless loop.

This is also the supports answer to it :

[22.00.04] : At this point in time we don’t have a way to actively make changes in the game itself. However, Our developers are already aware of the situation with the loading screen with Ancient Elveria and are actively working on this issue. Although we don’t have an expected ETA we expect this to be solved shortly.

Hi there, I hope you are doing great.

Apologies, we are currently investigating that situation. Can you provide me the name, class and server please.

Looking forward.

Sorry Stooh, I already reached out to support through live chat and got it fixed, Nitesh got my back :pray: Anyways I hope others find this thread and avoids the issue until fixed

No worries, good to hear.

Best of lucks :slight_smile: .


I have the same issue. Tried to enter the scenario and game freezes. Restart game, try to login to this character and I am back to a frozen Ancient Elveria loading screen.

Server: Mari
Char: Flub

Currently on chat with AGS support. Tech is saying its not possible to move a character, which I already know is not true because I’ve already had it done before.