[English] Localization Bug Megathread

Quest Completion Rewards Window


The game still reports “Expedition XP +1234” it should be “Mission XP”

Gunslinger: Target Down Tooltip Bug



Damage calculation is clearly bugged on it.

Card guide on CH or KR

Egirl Guide text

Vern Quest

Dialogue cut-off.

Anikka: Main Story Quest > Intruder’s Intent

Dialogue cut-off.

Atk. Power Reduction Engraving (aka Rust)


Wrong description. Rust lowers your attack power, not your attack speed.

West Luterra Main Story Quest: Militia Leader Cassleford

“As for Prince Thirain, he’s already had …” conversation is duplicated.

You have no ships to apply this skill .

Should be something like " You have no ships to apply this skin . "

Multiple issues here.


Should be just Store.

Skins menu should be Avatar because they are Avatars in the Founders Packs.
Meaning that the “Skin” above the image of character should also be “Avatar”


EXP / Silver gains notification sometimes is just stuck there forever.


Does not represent function itself .
Proper text here should be “Members” / “Roster” .


Part of the text is not showing up like it should.

Instead of “Resist” should be “Decline” ,because you are declining offer that was proposed to you.

1 Like

Long text on controls in Ship Station

Added links to a couple localization issue megathreads posted by other users. There’s some overlap but it’ll help when I categorize all of the localization issues at the end of the beta.

“Mission” quests are labeled “Expedition” quests


There are 3 names for the account-wide progression system.

Mission, Expedition, and Account. Most of the stuff is labeled mission in-game, but the pop-up art when you level up also says “Expedition Level Up”.


Not sure what Amazon is going to decide to go with, but it would be good to unify the name across the game before release. Otherwise it can be confusing.

NPC Rapport Window >> Emotes


“Emote” is not the same as “Emotion”. “Emote” is a verb, “Emotion” is a noun.

Daily Emote Count

Remaining Count 1

I would also change the “Confirm” button to “Express”, since the music rapport window has “play” as its button, it makes sense to also have a fitting button for the emote window.

NPC Rapport Window >> Play Instrument


Improper wording.

Daily Song Count

The game has a habit of adding unnecessary words such as “Max Music Play” in this case. The more unnecessary words you add to a line, the more difficult it is to read as a player. “Daily Song Count” gets the point across and uses “Song” to match the way the actions are named ingame.

I would remove the word “Acceptance” here.

NPC Window >> Rapport Rewards



Thirain Rapport Quest: Thirain’s Conundrum

Missing spacing on both sides of “Cassleford”

Missing spacing before “people”.

East Luterra Main Story Quest: Stronghold Ceremony

The voice acting on this cutscene is largely off from the lines of text that appear on the screen.

Stronghold >> Rename Stronghold Window


Missing space “upto” = “up to”.

Stronghold >> Rename Stronghold Confirmation Window


Random line break before “?”

Stronghold >> [Hardship - Ice/Wind/Fire/etc.] Pet Tooltip


Typo on “Specialized”. Missing space before “Specialized”

Stronghold > Proceed with dispatch window


Missing space after “Adaptation”

I would change “quest” to mission, since you’re sending the ships on missions, not quests.

“Adaptation” is a more arbitrary way to say “Success”

Stronghold > Stronghold UI


“Building Info” doesn’t fit.

Stronghold >> Lab >> Merchant Contract: Trade Permit


Text cut-off.


Additional space before [Duekhyeon]. (Research complete window)

1 Like

Mining Guide Video on take first time

I want to add to this that I ran into this exact same issue, instead of a video I also just had these weird numbers. Furthermore, clicking the (?) icon left to “Mining level” caused a client crash. It fixed itself later, don’t know if it was a relog that worked or finishing the [Guide] quest for my second life skill.

Great work you’re doing here, I’d like to add one myself:
The “stars” ★ are not displaying in the fields that use them. Examples include the “Class Difficulty” rating at the character creation screen, and the Amalone Star Ratings on the foods in the Adventurer’s Tome. The stars are also missing in the dialogues that pop when you consume said foods for the first time.

1 Like

broken string

Broken string code “!!” probably supposed to mean text in bold or something else.

line break

Line just cuts itself in random moment.

random symbols

Same as first one,broken string code with “!!” .

account exp

Not “Mission XP” but “Account XP”.

combat skill

Instead of 3 Life Skill Points it should be just “3 Skill Points” .
On top of that, source of that item should not be only [Quest] Luterra Castle - A Light Cast over the Dark Fields.

broken UI

Skill type line is broken,part of the word “Point” is eaten by UI.


Wrong Source of the item . This item is available from various places and not only the “Justice never dies” quest.

Broken string, missing text and on top of that has missing spacing before "warning for 1st … "
Also on the button for Deathmatch there is text " (Reward " seems like its not finished or missing second part.

Text is too long . Should be " Next Season will be announced soon " .

Second issue there, “Ranking Board” button is missing one letter.


Last string is missing half of its text.

WarriorType,MageType - What is with this “Type” ? Just put , Warrior/Mage/Martial Artist/Assassin/Gunner .

Second issue there -

Exclusive PvP Hair ->> Should be Exclusive PvP Headwear .

Title Menu
“are applied to all characters in the Mission” , what mission ? It should be “are applied to all characters on the Account” or something similar to that.
Also second issue there is last string. “symbols identfies title to earn the points.” There are two mistakes, first is - What symbols ? - Second is word “identfies” and should be “identifies”

King Luterra’s Tomb Location Text



East Luterra Main Story Quest >> With Gratitude >> Kazeros VA Missing

Missing the second half of the voice acting for Kazeros on this cutscene.

1 Like

East Luterra >> Blackrose Chapel MSQ: The Secret of the Chapel Graveyard

Improper translation.

“Every joint in my body aches.”


Quest title cut-off.

East Luterra >> Blackrose Chapel MSQ: Preparing Disguise

Missing space after “an” before “appropriate”.

East Luterra > Blackrose Chapel MSQ: Perfect Disguise



Says “praise” or “pray” Q/W button.

Change to “Perform Prayer” “Perform Praise”

East Luterra > Leyar Terrace MSQ: Puruus and the Land of Purification

Typo “outsiders”

East Luterra > Leyar Terrace > Quest Completion Window


Game is starting to report “Expedition XP” now.

So the game starts by awarding "Mission XP’, then transitions later into “Expedition XP”, to gain “Account” levels, to earn “Mission Rewards”. Inconsistent naming of the Expedition/Mission/Account progression system throughout the game.

East Luterra MSQ: Sad Premonition > Thirain’s Letter

This reads more like lines of code rather than a letter due to short/inconsistent line breaks.

East Luterra MSQ : Sad Premonition

Extra space added before “Father”.


East Luterra > Borea’s Domain MSQ: Drums of Resistance

Missing space before “Kazan”.

East Luterra > Borea’s Domain MSQ: Rekindled Fire


Quest directions should be “Ask the Umar blacksmiths”. There are multiple blacksmiths, and the quest asks you to question 3 of them.

1 Like

Island is missing from game and cant complete the quest