Fix your game. Can't connect to EAC issue been going for days

image

Second day in a row. Had the same issue last week.

How hard is it to make your game work as it should. I’m just asking to be able to play in peace, but this god awful tool keeps getting in my way. Lots of people are having issues.

Take this issue seriously.

Works perfectly fine for me every day. So has to be something on your end or anti cheat connecting to you specifically or something. Haven’t had this issue once.

Muted and ignored. I hate people like you. “I don’t have this issue, therefore its not really happening”.

Did I say it’s not happening? I literally said that it can’t be “How hard is it to make your game work as it should.” if the game literally WORKS AS IT SHOULD for majority. Also why are you making a new thread if there is a thread with 180 replies about this already.

Are you always this rude and insulting to people? No reason to treat others so poorly.

No.

I already tried virtually everything and none of it works.

Its not on my end, its on their servers. There’s a bunch of people over at the Game Support section of the board having the exact same problem.

ok, was worth a try.^^

Why would you come to the forums to post about this? AGS has a support email you can open a ticket with them. The CM’s can’t do anything for you. At least you could post it in the correct forum: Game Support

I have sent a ticket and they said they’re not responsible for it.

I also already made and am making noise over at the Game Support section. Why would you come to the forum to complain about me having issues? Really weird my guy.

And you thought you would get a different response here?

¯_(ツ)_/¯

Welcome to the block list. Enjoy your stay.

LOL you are a tool and right back at you.

Out of curiosity what region are you playing on?
I saw quite a few in SA with this issue yesterday posting in the forums. I havent had this issue on NA East thankfully.

Just trying to collect a little bit of data to see if I can find a solution a player can take.

I’ll assume you’ve already done the basic steps, after all I think you said you already tried several solutions.

NA East - Sasha server.

And I’ve noticed too that for the most part it looks like its happening to people playing from/on SA servers. I do have some friends in NA East and West who live in the US and are having the same issues though.

Yes I’ve tried everything that has been mentioned on the subject. Verified game files, updated Windows, Repaired EAC, uninstalled it and installed it again, tried a VPN that a CM recommended on this board (Which is crazy to me that they would recommend using a VPN), tried uninstalling Lost Ark from Steam and reinstalling it. Nothing helps.

I played just fine since the game came out. This problem started with the Vykas update. I’m 100% positive its not on my end.

1 Like

So trying to find solutions just brings me back to generic trouble shooting steps.

I know some others have posted about this and stated Cloudflare warp is working for them.

If you haven’t seen it already, check out this thread: