Game Crashes w/ Controller in Auction House

Whenever I attempt to use the auction house while my xbox one controller is on, the entire game crashes. Most often, a steam keyboard overlay will appear in the center-bottom of the screen, followed immediately by the game freezing up and crashing. Sometimes it just crashes without the overlay appearing.

This is reproducible as it happens 100% of the time I try to use the auction house while my controller is on. So far, I’ve just turned it off before opening the auction house, but I figured I should probably post about it here just in case anyone else is experiencing this.

Steps I’ve done so far:

Scanned registry as well as for corrupt files.
Hard reboot/resets.
Completely reinstall of game.
Made sure xbox firmware app was fully updated for the controller.

This is a recent thing that has been going on for maybe a couple weeks or so now, maybe three weeks? Not entirely sure. It’s not super game-breaking for me as I simply have to turn off my controller before opening the auction house. It is quite annoying though.

Hello @maniofold

The consensus from what I’ve read online is that it’s something to do with steams handling of controllers, and it’s detecting that you’re using one. Since controllers don’t have keyboards, while yours is turned on, it’s opening that keyboard so that you can type with the controller.

I’m not entirely sure why the game would crash as a result of this, but could you try these steps:

  1. Open the Steam application
  2. At the top left, select Steam → Settings
  3. Near the bottom of the list, select “Controller” → General Controller Settings
  4. You’ll get a window that opens with the title Controller Settings. If any boxes are selected, please unselect all of them.
  5. Close the Steam application and Lost Ark entirely and relaunch Lost Ark and see if it still does it

Please let me know if this helped or if none of those boxes was selected!

1 Like

That’s the workaround I use to avoid the crash:

I’d just like to say, tentatively, that so far this has worked! No crashes yet after fiddling with the auction house while my controller is active for a solid 10+ minutes. Thank you very much! That doesn’t solve the annoying overlay keyboard that keeps popping up though. I’ve tried everything I can think of to stop that from popping up when I click in chat boxes. I don’t suppose you have a solution for that too?

1 Like