Game doesn't launch past Easy Anti-Cheat

This is really frustrating. It is my second day troubleshooting, trying to get past this launch issue. Same as everyone else, after the Easy Anti-Cheat splash window bar is complete, Lost Ark does not launch at all. I have tried the following multiple times and different combinations with zero success:

  • Updating my Windows 10
  • Updating my graphics drivers
  • Verifying integrity of Lost Ark game files
  • Repairing Easy Anti-Cheat
  • Disabling my firewall
  • Replacing my Windows Defender with Bitdefender
  • Running the game as an Administrator
  • Having Task Manager open and ending all background tasks that may interfere
  • Uninstalling and reinstalling Lost Ark
  • Restarting my computer

I am currently at the point where after the Easy Anti-Cheat bar is complete, an error pops up and reads “Easy Anti-Cheat: Untrusted system file (C:\Windows\System32\usp10.dll)”

East Anti-Cheat

Lost Ark Running


Hello @opheliamist, welcome to the Lost Ark forums,

First of all, thank you for sharing all the troubleshooting steps you have done so far, after some research it seems that as you mentioned here:

The problem is with the usp10.dll file, have you tried replacing that file or done any troubleshooting regarding that specific .dll file?

I’ll be waiting for your response!


@Jormungandrh I’ve tried running the DISM but it didn’t launch either - is there a step-by-step process you could link me? Perhaps I am doing it wrong.

You can follow the information in here:

Let me know how it goes!


Hi @Jormungandrh, unfortunately the replaced “usp10.dll” file does not fix the issue. The Error still occurs.

bump because I’m having the same issue … (except I don’t get the error you mentioned in the last line)


@leonistiredoffishing, the error I am receiving only occurs because I downloaded Bitdefender. If I uninstall Bitdefender, I basically am reduced to the same issue that many others and yourself are experiencing - the fact that the game simply doesn’t launch after Easy Anti-Cheat has completed it’s check. All I want… is to experience the joy of playing the game… but here I am dying inside LOL.

1 Like

ah alright.

haha… I spent so much time looking at the guides/gameplays, thinking about classes and things like that… and when the game actually launched I can’t even launch the game. :sob:
I’ve been trying for so many hours since the moment the game launched, I’m tired lol I give up trying on my own at this point. If we see a solution I’ll do it, but I give up trying on my own… I hope we receive some sort of compensation for this nonsense :face_exhaling:

1 Like

there may be a clash in the easy anti cheat folders,

when this has happened to me in the past i have just reinstalled easy anti cheat in my steam folder,
as there may be an outdated certificate or authority in your anti cheat folder, causing a clash with Lost ark/Amazons servers (this happened with New World)

Repair/Reinstall EasyAntiCheat -
for this go to Lost Ark on your Steam library > click the gear icon > Manage > Browse local files > Open the folder EasyAntiCheat > run EasyAntiCheat_Setup.exe > Try repairing the service, or uninstalling and reinstalling it,

this worked for me Saturday morning when i had this exact issue you had.

also to add to this, if you are using a VPN, to play the game, this could also be the reason you cant play, as Some people had this issue when playing on the Korean version.

1 Like

I did both repair and uninstall+install again, that didn’t work.
and I’m not using a VPN for lost ark.
thank you for responding though ^^

uninstal and repair of the Game?

or the Easy Anti Cheat?

Easy anti cheat

another thing you could try,

is checking for Graphics updates, but also, doing a clean boot,
its a bit more indepth,
but you may have things running in the background chewing up your Memory,
and Lost ark is a Memory intensive game sometimes using upwards of 15gig of memory to run,

it may be crashing instead of not launching,

you can try turning off unwanted programs that are running in the background if you want? and untoggling them to not run at startup might help the pc.

if you want to do this,

Windows Key + R
Type: msconfig and hit enter
go to the services tab
hide all microsoft services ( you need to do this or your PC will not run)
click disable all, or untick the ones you dont want running,
go to Startup tab, and then open task manager and do the same for programs/tasks you dont want being run at startup.

there might be something running in the background of your PC that is chewing up memory, and not allowing you to play the game.

another thing you can do is forced window mode,

if the game launches for a Little bit you can Alt+Enter, and it will force it into windowed mode, smoothing the strain on your PC.


@Turtler I really appreciate this detailed step-by-step response. I have just tried these instructions and sadly my game still does not start.

1 Like

im at a loss then,

im sorry you’re unable to play this amazing game at current.


I’ve checked for graphics updates, and I checked for unwanted programs in the background, and did a clean boot. None of them worked unfortunately. :sweat:

Thank you for responding! ^^

edit: forgot about forced window mode, don’t have the time to open the game and try that anymore right now, but I’ll update a couple of hours later.
also do you think closing chrome and only keeping steam open would make a difference? I might try that too

1 Like

Do either of you run Discord overlays?

it could be clashing with that?

also if your running an overclock maybe stop it and see if your game will run from that?

anda re you running the game as administrator?

1 Like

Nope, no discord or overclocking.
I’ve running lost ark as an admin before (once) but it didn’t do anything, even the EAC screen didn’t appear

1 Like

I was having the same issue…came here and read some suggestions to fix.

Read the following:
Windows Key + R
Type: msconfig and hit enter
go to the services tab
hide all microsoft services ( you need to do this or your PC will not run

Noticed I had 2 instances of EasyAntiCheat listed and disabled both…rebooted the computer and relaunched game…EAC/Windows ask to update settings which I allowed and game launched with no issue.

Hope this helps.


I made an account to say thanks @jeff.husted

The steps you provided worked for me when nothing else did. I went into the services tab and all the way down I had one Easy anti cheat process. I unchecked it and restarted and we are good to go. Thank you so much.

1 Like