Game doesn't launch past Easy Anti-Cheat

Awesome, good to hear! :grinning:

1 Like

Hello everyone!

It makes me very happy to see the community helping each other out! Special thanks to @Turtler and @jeff.husted for step by step options and suggestions!

To everyone that after trying out all these options and still have the issue I will ask you to please contact our Live Support for further assistance.

You can reach us using the following link: Contact Us | Amazon Games

This issue seems to be something really specific which we don’t have “troubleshooting steps” and I do believe requesting an escalation with our developers might be the best option.

I do want to thank you for your understanding and patience.

Feel free to refer my colleagues to this forum post. I hope this helps, feel free to tag me if you need anything else.

Best of lucks and I wish you have an amazing week!

:dragon:

1 Like

Hello everyone,

I have the same problem. I see EAC being launched, and then nothing happen. The game doesn’t launch. I’ve tried every steps people mentionned before without any success. I’ve also tried to reach the tech support with the link provided by the moderator but it’s asking me a ton of questions just to finally say “my game doesn’t launch”. Then, I click to send my demand, I prove I’m not a robot by clicking on boats and trucks, and then nothing. No confirmation, no feedback to tell me it has been send, nothing. So I don’t know what to do excepted coming here to say I’m a bit annoyed by this and asking you to tell me if there is another way to finally be able to play please.
Thank you.

1 Like

If you made a ticket check your e-mail for a confirmation, if you want a more direct response then what you can do is select Live Chat and talk with an agent there!

:dragon:

Sadly this did not work for me, but thank-you for posting the solution as I can see it did help another person out!

This is my issue:

NVIDIA_GeForce_Experience_hoZeh6PiSd

I’ve seen this same issue with other games, but they generally resolved itself, if I load the game a 2nd or 3rd time, but this did not work.

Tried the various methods that have been mentioned in this thread, but I’m still here with the same issue.

Where is this “Live Chat” option you are talking about? I don’t see it.

Also, when looking at EAC options there is no live option here either:

I have submitted a ticket to the EAC Support as well, but no email response.

The game loaded fine last night, and now that it’s the weekend where I can play more, I can’t play :frowning:

Same over here I have the same issue and followed all the steps everyone provided above.
I don’t even know what happen, this morning I was playing the game then left to watch a movie came back and it gave me that launch error.

Edit: I have seen people on steam forums and they are saying they get the EAC error load after the new steam update on Lost Ark so that could be an issue to look at. @Jormungandrh

I see. I scoured steam forums as well. Looks like there was an update somewhere where the game conflicts with antivirus.

I followed this poster by adding Launch_Game.exe and LOSTARK.exe from where your game is installed. I use a different location so use this path as a reference \steamapps\common\Lost Ark\Binaries\Win64

edit:

To be clear I added those 2 executable to the exceptions list (or allow files) section of my antivirus, and it seems to work.

2 Likes

I’m having this exact same issue, was playing and logging in perfectly since launch. However after the last update I can’t get back in. I completely uninstalled all anti viruses, updated gpu, full bios, win 10 updates, reinstalled the game, reinstalled/repaired anti-cheat system.

I don’t know what else to try.

Just want to confirm this worked for me. I have webroot and once I added to the allow list it loaded just fine.

1 Like

Hello everyone!

Thanks to @Wynn86 for adding a new possible solution for anyone who still has the issue:

To also respond about your post here:

To see the live chat you need to select the categories relating to your issues, it will then show the contact options! :slight_smile:

It will look like this:

.

And remember if you still have the issue after all the possible solutions provided in this post then please contact our support:

Thank you everyone! :smiley:
:dragon:

Finally, I fixed mine. most guides only specify to run LOST ARK launcher as admin but you also need to run the steam and Launch_Game as admin. after running it all as admin my game launched instantly.
hope it helps

Is there a step by step process you could explain for this?

Go to desktop look for steam right click the click properties then click compatibility then you check the box that says run administrater

For the LOST ARK AND Launch_Game you open steam then look for lost ark
Then right click then press browse files>binaries>win64.
There you can find Lost Ark and Launch_Game
You do the same steps you did before.

right click then properties Lost Ark/Launch_game then compatibility mode the find the run as administrater.
Hope it helps

i playd the game like 200h without issues but now my easy anti cheat wont let me in the game anymore. i tried most of the things listed here and nothing works. any other solutions ?

1 Like

@Jormungandrh I have the same issue, I started a post on it without seeing this one.

https://forums.playlostark.com/t/launch-error-failed-to-start-the-game-2/217963/2

I have tried everything possible that I have found online… sometimes the easy anti cheat just goes away and the game just shows up as I need to launch it again…

I am lost, this is a random thing that has happened with no changes to the system, updates or anything, 1 night turned off the computer after playing, came back the next morning and boom… this issue.

I have also made a ticket… and awaiting a response.

EDIT: Sometimes when i spam trying to launch the game i get another popup saying the following:

WinLicense
An Error has ocurred while loading imports. Wrong DLL present.

same here… i just spoke to them on live chat they said devs are aware and we just need to wait…

Yep, it also got me. Error 23
Everything was fine in the morning, i closed the Game, turnd off my PC.
Came back from work later and i got this Error. Nothing was changed on my Client Site.

Edit: It works again, i didnt really do much.
Just restartet my PC and tried to start the Game a few times. EAC sucks really hard.

Finally! that fixed it for me! went through all the launch files including steam its self, unticked all the “compatibility boxes” and its started first time!

Thank you @Scrymer

1 Like

Maybe necro of topic but wanted to say this helped and add to it.
I am trying to see how game would run on a low laptop I have.
It seems the VPN I have on the laptop had auto launched and this seemed to make EAC block the game from starting also after the VPN was stopped.

Going to start up services i unchecked/disabled EUC but also the VPN services listed.
Then restart and game worked.