Game frozen in loading screen

The game got frozen after the Tripod Studios logo disappears (sometimes on the first logo though, but I assumed it’s the same), and then all I could hear are seagulls’ sounds.
I really need help with this problem cuz tomorrow will introduce new class and I really hype for it.
My character name is Florentinodt, Server: Sceptrum.

Hi @165445 , Welcome to Lost Ark forums, hope you are having a great day.

I’m sorry to read you are having issues.

I would like to provide some steps/troubleshooting to see if we can improve your experience so far.

First lets run an integrity check on Steam:

1-Restart your computer and launch Steam.

2-Next, you can either right click the game in your Library, or click the gear icon from the game’s Library page on the far right.

3-From the drop down menu, select Properties.

4-Select the Local Files tab and click the Verify integrity of game files button.

Steam will verify the game’s files - this process may take several minutes.
Steam Support :: Verify Integrity of Game Files

Please, let us know if this helped you out.

I forgot to mention about this, yes I has tried restart and verify, but it seems didn’t work for me.

Thanks for letting me know what you have try already.

Lets try something else, please check from the task manager that the game is completely shut down with no background process running.

Then proceed to repair Easy Anti-Cheat

  1. Open the Lost Ark Application in your Steam library.
  2. Open Settings, select Manage, and then Browse Local Files.
  3. Open the EasyAntiCheat folder.
  4. Launch the EasyAntiCheat_Setup.exe file as administrator, and run it.
  5. Select Repair.
    (The EAC Folder should be in:
    C:\Program Files (x86)\Steam\steamapps\common\Lost Ark\Binaries\Win64\EasyAntiCheat)

Once this is done,lets run again an integrity check on Steam, restart the computer and try.
Let me know if this works, thanks for the patience. :sparkles:

Thanks for your help, but this solution isn’t worked as well.
I have try to log in another account to see if I can advance to the choosing servers screen, but it’s also doesn’t work.

Ok, I have found the solution:
I just update the driver to latest date, and then launch game perfectly fine.
Sorry for bothering you helping me, I should have update it earlier.

1 Like

Hey @165445, I’m glad to read that the issue was fixed, thanks for letting us know, if you need something else don’t doubt on reaching us again.

have a great day, enjoy the lands of Arkesia. :man_mage:

1 Like