Game unable to load after eac anti-cheat starts

I wanted to make this post as my game was unable to load the loading screen featuring a character from the game after the eac anti-cheat fully loads and was wondering if anyone had any other suggestions?

I tried “Repair/Reinstall EasyAntiCheat - for this go to Lost Ark on your Steam library > click the gear icon > Manage > Browse local files > Open the folder EasyAntiCheat > run EasyAntiCheat_Setup.exe > Try repairing the service, or uninstalling and reinstalling it” which didn’t work

I also tried verifying the game files, Tried restarting my computer and steam and launching both or everything in admin and still has not worked.

I’m currently Reinstalling the game itself hoping this may fix it but in the case it doesn’t would be out of ideas ):

im having the same issues, nothing has worked. including everything listed my OP and reinstalling + drivers and software updates.

Lost Ark not starting up the post by nephyr here fixed my issues

Hi @Oathsworn

Hope you doing great!

I’m so sorry for the issue your are having and the game doesn’t start properly.

Thanks a lot to @Hajibob to sharing the post with a fix to this issue.

I like to share the steps with you to try it and verify if is works for you.

Here is the steps that was sharing in the post:

Please let us know if the can fix the issue with the steps or you still have the same issue. :wolf:

Hi @Kagami .

This doesn’t explain why yesterday everything was fine and today it’s not working anymore…

Hi @Tumerion

I really understand you concern about it.

I have make the report about the situation to investigate the issue.

I also recommend you if you have the same issue and none of troubleshooting help you with the issue, please contact our live support channel in order to help you further and create a ticket to the Devs team to collect more information about the issue and help them to investigate it.

Here is the link to contact live support channel:

Hope this information help you! :wolf:

1 Like

The problem is that after fixing the “can’t open the game” issue with the fix you mentioned now I get disconnected of the game after 5-10mins of playing which cause me to lose a whole chaos dungeon, this didn’t really fixed anything

I have been having the same problem, tried the suggested fix but all that is happening is I get a popup box redirecting to an easy anti cheat webpage with no solutions to the problem instead of it just hanging.

It has to be a problem their side as everything was fine up until midnight last night and now totally broken with nothing changed on my end.