Game wont start, stuck on Lost Ark Icon

Ive seen a lot of post for people experiencing similar issues. But also a ton have been resolved, sadly mine hasnt. Ive been going at for almost 20hours trying and failing.
Whats happening is, the game is downloaded fine and whenever i try to launch it, it starts to run and stays running but it never opens the game window. Itll show up on my task manager as Lost ark client and it says its running but i can never get past the Lost Ark Icon after the EAC load screen. I was able to access the game from my friends computer so its not my account and obviously something on my end? But ive tried every single fix and suggestion ive seen so far.

Unistalled and reinstalled
EAC repair
Restart game/steam/pc
Update windows/drivers
Verify integrity of game files
I even factory reset my game and tried that
But not a single thing has worked.
Spec wise my pc is good, I did play the alpha few months back and never had issues. But sadly idk what it is but im just not able to play this game.
IF ANYONE knows any possible fix, i would gladly appreciate it

I have talk to tech support via online chat and even over the phone. But there was no help there either
Ill keep trying, but i figured id post just in case someone might be able to help T.T


same issue. none of the suggested fixes work.

Hi @chrisandsleepy and @Fowlercyoxx and welcome to our community :dagger::crossed_swords:

I am so sorry that you are still having this issue and none of the fixes seems to be working, this sounds frustrating and we want nothing messing with your Lost Ark experience.

If you tried all of the steps listed by @chrisandsleepy then we can try to troubleshoot your firewall, check the steps in the following link:

Let me know if this helps with the issue :european_castle::horse:

ya thats all been tried.

I have the same issue.
First time I had 105 - 105: corrupted data found. Please verify game data using the launcher menu

After updating drivers, verifiying files, adding full screen and reinstalling the game I no longer see the error message but the game won’t load.

Can someone please help? I’m not sure why this corrupted as I played for 5 hours then died and tried trouble shooting for 20hours…

Someone please help

Just bought the founder pack and am ahving the same problem. If I can’t get it to run I have no other option but to refund it.

@Roxx can we get some traction here?

A currpted file has been created

follow the steps here to fix the bad files

if you read the thread youd know thats already been done many times

Greetings Guys, I had the same problem, and one of the things I tried was to go to the task manager (while the icon was still on the screen) and finished the EASYANTCHEAT process and the game started, I hope I helped because it worked for me.

1 Like

can you replicate this? any chance for a video?

Im having the same problem. Does anyone knows how to fix it ?

Would like to keep this topic relevant as this is also happening for me. Question. Did any of you pre load this game as well and wait for the official launch to play? I did. Currently uninstalling and re installing the game. If anyone has an update or something to try other than what has previously been stated please keep this topic updated!


Can we get some assistance here?

over 4k views and no responses. the only response was to look at firewall settings. which didnt work at all.


1 Like

Until this gets fixed.

Right click on a blank spot on your Task Bar. Select Task Manager, third from the bottom. Select More Details if all of the task names are not showing. Under Background processes scroll down until you see LostArk Client. Right click on that task and select End Task. Start the game again through Steam or Desktop icon. You can do this while the Steam client is running.

Hope this helps. :slight_smile:

This is happening to me too. I’ve seen every threat, discussion or video i could to see if i can play, but nothing has worked.

It is not the anti-virus or the anti-cheat, i play other games with Easy Anti-Cheat and they work perfectly, the problem should be in the client.

The last thing i wanted to do was re-install the game, but it’s my last chance to see if i can play the game, i will update in this discussion tomorrow if it worked or not.

But if someone reinstalled and have the response rn, it would be better.

Hope we all can play the game soon, this game is awesome, it just end up coming out in a horrible way.


Would like to update that I tried this, just uninstalling and re installing the game, and it worked! It was the only thing that worked for me. And yes, I had pre downloaded the game before the official launch day for f2p. Hopefully it can fix it for other people too. Nevertheless the server today was very unstable

i tried uninstalling and reinstalling and it didnt help any at all