Garden of despair entrance

Hello. Got some issues with the dungeon entrance. Done the daily twice, got two keys but entrance wont spawn. Guess i’m missing the last quest in the chain, but ain’t got any quest everywhere. Nothing in the npcs and nothing in the diary.

What’s yer item level? You need a specific one, I think +1325 was it.


And you did all of these?

Are you per chance on Thirain? There are some server issues, maybe it’s related. Otherwise this might be a bug, yeah. Maybe try restarting the client or verify steam integrity files (That’s the first thing anyone would require you to do before trying to forward this bug to SG)

The problem is this. As I told in the post, i’m missing the final quest, but i can’t find nothing or noone to take it. I already did all these thing: switching chars, restarting, verify the integrity. All of this crap. But still nothing. Otherwise i wouldn’t have write here. I’m on Procyon

Just tried to help, because people here wait weeks if not forever. Experienced this as I’ve reported couple things myself. I do not assume you to be an idiot and not assume you to be a perfect being, so I just tried some tips that you might have not considered.

Hope your bug gets noticed.