Gear Transfer deleted my gear

I was trying to do my T2 gear transfer on my new gear by taking a T2 chest and weapon from level 0 to level 1. Now It shows i have no equipped gear on those items and i also had my earring replaced back to T1 abyssal. So instead of sitting at 820 Ilvl I am now stuck down at 536 and can’t progress back up to T2 without restarting completely.

Solved with the pet storage work around, extremely scary bug thankful it was an easy fix


Greetings @UncleBenjin

Thank you very much for confirming a workaround fixed it!

Is there any way you can toss that workaround here? It would be super helpful for the sake of assistance.

Persistence is key, regards,

:spades: JWarlock :diamond_shape_with_a_dot_inside:

Something similar happened to me but what actually happened:

I was doing chaos dungeon with almost full inventory and specific item was looted to PET STORAGE because it didnt fit to my inventory.
Then I proceed to do the transfer without giving much thought and when I transfered my gear everything worked well but the item was in pet storage, not the regular storage so it took me a minute to find it because I didnt know it was in my pet storage.

My first though was also did I dismantle it or what happened but i was just looking from wrong place. Could be avoided if the item was automatically equipped instead.