Guardian Raids are bugged, can't enter

I believe my character is bugged.

I am on part 2 of the Guardian Quest, where it asks me to go kill Urnil however I can’t queue for any of them.

I am ilvl 390 and have the contract part of the quest in my completed tab and my 302 alt can queue into them just fine, with the same quest in his completed tab.

Please help.

Bump. Found someone else with the same issue. Is there a bug report in game?

Bumping - also have this issue.

My main Sorc 363.33 ilvl cannot enter Guardian Raids even though I’ve completed the [Guide] Guardian Raid Qualifications Certificate (seen under Completed in my Quest Journal)

I also have the follow up quest: Find the Guardian to kill Ur’nil.

I boosted a second character and he’s able to queue into Guardian raids without issue.

I am also having the same issue as above.

Edit - tried abandoning the quest and re-doing, it did not work.

Further Edit: It is not a bug, there is another quest called Guardian Qualification Certificate or something, finish that one first and then you can do the raid.

1 Like

Bump. Same issue. The Guardian Qualification Certification quest shows as completed, I have the kill Ur’nil quest, and still can’t queue. Alts can queue no problem.

same issue here

Same issue here. Have done the certificate quest, i have the Ur’nil kill quest up and cant open or join Guardian boss (and i have 450 gezar score on main and 302 on alts).

My alt can join the guardian with no issue :s

Plz fix it as soon as possible, we cant do our dailies :s

Same issue my alts have no problem while joining raids but my main cannot enter the raid. I sent a ticket but didnt get any replies.

Same problem like u … i think speedpass alt broken my main …

Seeing the same issue on my end as well. Guardian certificate quest is completed and on (2) of Find the Guardian quest.

Same here, my main sorc ilvl 380, all pre-requisited quests done, can’t enter guardians raid, but my alters can.

Alter can enter:

Main character error:

1 Like

Everyone! I had this same issue. Press J to open your quest journal and check the In Progress tab. Look for a purple quest (it should be pointing you to Guardian Raid Manager Seifeltz standing NEXT to the board). Make sure you click the checkmark next to it so it’s tracked, then you can talk to him.

This fixed it for me!


I just tried this and it didn’t work sadly. I can’t interact with any Seifeltz’s let alone progress the quest Find The Guardian.

Actually, I think the initial quest is to sign a Guardian waiver or something, THEN it tells you to talk to Seifeltz. My bad.

THANKS!!! it actually work for me. You need to track this quest “Guardian certificate…etc”, then press F5 to read the certificate, now you can talk with Seifeltz and enter guardian raids

Yeah, well. You just were on the wrong step.
Our problem is that we are on the good quest (the quest want us to kill Ur’nil) but we can’t queue any Guardians.

I’m in the same boat with my main character, I am unable to sign up for them and there is no indicator for [Guide] Guardian Raid Qualifications Certificate which I had completed previously, I’m now speed leveling a second character so I can do raids.

I have this complete, still can’t join

Same exact thing happens to me… I boosted also an alter, and I can join guardian raids with the alters but not with the main despite my main having completed [Guide] Guardian Raid Qualifications Certificate and being 486 ilvl.

Same here