Guild contributions not working

Since the Vykas trouble a few days ago, the character i was playing with when the crash/hack happened can no longer contribute to guild. I cannot make any kind of donations they are all greyed out. Can you please fix this?

Hello @Linche,

Welcome to the Lost Ark forum, I’m really glad to see you are here at the forums and hope you can enjoy your time here and at the game as well!

Regarding the issue you’re facing I’m really sorry about the situation, I know this is a huge inconvenience for you and your guild, the first thing I would suggest is to try this:

  1. Run a Steam Integrity check here > Steam Integrity Check.
  2. Completely uninstall and reinstall game if not resolved after an Integrity Check.

If this doesn’t work I can recommend you to reach us via chat using the following link: Contact Us | Amazon Games

Please make sure to have the DxDiag ready once you reach support, you can pull it following this steps:

DxDiag report:

  • Go to Windows Start search bar and type dxdiag.
  • Click on dxdiag.exe.
  • When green progress bar goes away, select Save All Information and save the file to their desktop.

If you need more assistance please don’t hesitate in reaching us again!

Cheers!

Just so you know, nothing you guys said worked but i fixed it myself. I had to quit my own guild and re-join it. I wasted a lot of time doing that.

Well, that’s not encouraging. I just started experiencing this on two different characters in two different guilds. :frowning: