Hard stuck in quest "Honest Liar"

Hi there,

for weeks now I’ve had the quest “Honest Liar” in the questjournal, because I can’t progress.

The current task is to “Identify tip.name.treasuremap_301”.

Clicking on “locate” only brings up the Stern map with no hint where to go.
The quest talks about requiring the device in your inventory to be able to speak to Siltero.
Siltero is an NPC in the underground, but he will not speak to me.

The device that starts this quest has been moved from regular inventory to the Quest Item inventory. Interacting with the device there does nothing.

Am I missing something? Nobody I talk to knows what the issue is, for them it was very straight forward.

Edit: The devs are aware of the issue and are working on a fix, if you experience the same problem, all you can do now is wait.

Bottom level of Stern. Somewhere around the mailbox

If you were to examine the screenshot album, I am standing right next to where you, I assume, are pointing to. I can’t interact with the NPC, as I’ve stated.

oh duh, I missed that part. Sorry. Did you put a ticket in? or is this it? Hopefully support can fix it for you.

Edit: you probably do. But just to ask…you have the map still right?

I was told the only way to get help is to go to the forums. How do you write a ticket? I assumed there is no GM support.

Guess I just go to the Game Support section and create a topic there?

Just reminded me I can’t create a topic there, which is why I’m here in the first place, when I mouse over the “create topic” button it’s first of all greyed out and secondly the mouse cursor turns into “stop” symbol.

try creating a web ticket

I’ll try that, cheers!

You can create a thread there, instead of going on that part of the forum to create a thread, click the create button somewhere else and change the “category” to “support” in the top left.

To your quest, did you try stand there for like 1minute and spamming G?

The quest line is a meta quest how the game is “breaking”. That should do the trick from my experience.

I’ve read about that, but (from my understanding) this requires being in a dialogue with the NPC, because the NPC’s dialogue is a “…” and when people tried progressing the dialogue it would repeatedly show “…” again in the next dialogue part, making people believe nothing changes, when in reality the new text just looks like the last (the game actually has multiple instances of this occurring).

I’ve even stood there for a lot longer and spammed G, and nothing ever happened.

Did you try and abandon the Quest and pick it up again?
Sometimes fixes the problem too.

Otherwise AGS Support will just send you the normal bug fixes with steam file verify etc. What you can test too ofc.

The quest can’t be abandoned.

Great design… Out of ideas than, sorry mate.
Wish you good luck though, maybe support can help or some other person knows more.

Thank you!

The issue is reported to the devs.

I had the same problem. And just solved. I realized that I have mistakenly put the treasure map into another character’s inventory. I found it and transfered to roster stash, then voila.

Have you tried this?