Honest Liar Bug

During the honest Liar quest, I am unable to apologize to Siltero. It looks like after the event after I connected the robot, it ate my quest item. I have no way to fix it now.


Same for me, by receiving the Questline it consumed the rookie map and now I’m unable to continue because that dude in stern won’t talk to me unless I have the map

Same problem, this needs more attention.

Same problem here. Won’t talk about how many times I tried talking to Siltero afterwards and only getting “…”

It happened to me too. Furthermore, you can’t abandon the quest and retake it afterward.

Same issue here - the item is gone (even though the suspicious machine that starts the quest is there), there is no yellow circle to perform /apologise, the hacker npc just goes ‘…’ and the quest cannot be abandoned and takes space in the quest journal. I hope they fix this soon.

It’s not a bug, you just have to press G enough times and it will work eventually

1 Like

After going through the “…” many times, and completing that portion of the quest, the item is gone, and I do not have the next quest.

Thanks @ Vaest. Can confirm. I was only getting “…” when talking to Hacker Siltero. I tried spam clicking “G”, probably less than 10 times and he finally came up with an interaction I could click on.


People keep talking about “spamming G” when the NPC says “…”, but I can’t even talk to anyone to spam the interact button.

it looks like I’m having the same issue. Just got Honest Liar quest yesterday, Quest says Identify tip.name.treasuremap_301. then in description it says I found a strange device that says unusual things. I should take it to Siltero, the hacker in the Underground Market". Then in RED it says !!You need to have the item {tip.name.treasuremap_301} in your inventory or your roster storage to talk to Siltero the Hacker. I’m in front of Siltero and I get absolutely no dialogue to talk to him. I’ve logged into my alts, logged out of the game, and still no dialogue. Can’t cancel the quest and start it anew on my Main character either !! THIS ROYALLY SUCKS!!!

Hi, ran into the same bug today. My treasure map got consumed but I cannot apologize to Siltero the hacker.

The main reason why Noone wrote here 2 times is, because it works. Just keep spamming G, for like 30secs to 1min, it will work.

Spoilers ahead:


The whole quest chain you are doing at the moment is a meta quest with comments how the “game breaks”. If you keep spamming G, it works after like 1minute and the Quest continues.