"Honest Liar" Side Quest Bugged

I believe the quest took the item map already from my inventory without progressing me to the next part of the quest. The description for the item is also buggy/not-translated.


I have the same issue. I thought using the /sorry emote would help, but it doesn’t. Seems to be bugged

1 Like

Same here :raised_hand:

i thought had this issue and i was able to get the quest just by spam clicking him.


where is he in stern?

Same issue here unfortunately =/

Wow, it might not be bugged after all. Keep spamming “g” and it’ll move on.

The description/translation needs to be updated still.


just happenned to me today too

Hi guys, I have fixed this. JUST keep pressing G in a short time!!!


This worked, thanks!

1 Like

spam G for a few seconds worked! ty

1 Like

This fixes it. Just ran into this today myself… spamming G and he finally continued.

1 Like

This is not a bugg. its working as intended. You have to keep talking to him aka press G. I wont spoiler the story. But the idea of this whole story is a “Bug” the missingtooltip, the G spamm e.g. the whole point of this story is to meme a “buggy dungeon”.

the tip.name.treasuremap is not a translation issue, thats the funny and the meme of the quest

1 Like

Its not bugged he is not answering because of he is angry so u need to kep trying press g after that press sorry :smiley:


also worked for me

1 Like

Wow, that quest mimics being bugged so well that I got my first game client crash. Like, a genuine crash!


1 Like