I can't buy Royal Crystal

I can’t buy Royal Crystal, when I click on “Buy Now” it keeps loading and nothing happens. I already have a balance on steam to buy.

Hi there, brunnomenezes01!

I’ve moved this to the support section so you can get the help you deserve.

However if you do not receive a reply shortly, please submit a ticket here:

Hello @brunnomenezes01.

I am sorry to hear about the issue while purchasing the Royal Crystals, just to confirm do you have the steam overlay enabled? (I would recommend to double check as I have seen that for some people it has been disabled after a recent update), here is how you can check some of the common issue while purchasing:

Let me know if its fixed!

1 Like

There’s another place that you can disable steam overlay game specifically. If you go the steam library, and right click Lost Ark → Properties → General. I disabled this at some point and didn’t remember doing it but your suggestion to turn on steam overlay in Steam settings made me remember I did this. Just FYI.


Steamoverlay was disabled in the game, it was enabled only in the general settings on steam, but in the game settings it was not, I just enabled it and it worked. Thank you all.



I had this problem as well. My steam overlay was on in general settings but not in game spesific setting. Now it works after enabling it.