In-Game Purchases Still Not Happening

My steam overlay is turned on, I’m running steam in admin mode, still cant purchase anything in game. My crystalline aura is expired and I’d really like to purchase another one, but nope, can’t.

When I go to make the purchase, a circle spins in the background for a few seconds and then stops. Nothing happens, no error message, nothing.

I have a similar issue but i just get “error shop response slow” had it for the past 2 weeks now, Amazon support told me to run overlay, verify gamefiles etc i’ve done it all and nothing works.

I have bought an aura using crystals. The crystals were consumed, but no trace of the aura.

Hello @oribbbbia

I’m sorry to hear that you have not been able to make any purchases for Lost Ark. I would like to ask you to try the following steps once to see if the issue is being resolved:

i) Exit the game and the steam app. You can close the processes from task manager.
ii) Run Steam as administrator and enable steam overlay. Disable and re-enable if it is already enabled.
iii) Verify the integrity of files in steam. Steam Support :: Verify Integrity of Game Files
iv) Disable discord overlay if it is running.
v) Try using a different server if possible.

If none of these steps seem to resolve your issue then please reach out to live support:

Amazon Games

Contact Us | Amazon Games

Support for Amazon Games. Read support articles or get game & account help from Amazon Games support reps.

Kindly mention to the connecting agent the steps you have tried to no avail and a ticket will be created for you if the issue is not resolved by then.

I wish you a wonderful day ahead and great adventures in Lost Ark :smiley: