Is this Quest bug?

Candaria Territory
South Vern questline
Quest title: ‘At the Jouney’s End’
Quest: Break through Neilgarden Valley using tunnel magick
Destroy the magick watchtower at the entrace to the valley.

After I interact with the tunnel magick at the end of the bridge and am underground, I cant interact with the towers to break them. The tower doesnt even glow and indicate that it is ‘interactable’.

Cant continue questline.
Pls help.

1 Like

I got the same problem !

1 Like

I did this quest last night and everything was fine. If anything changed was only after the maintenance earlier D:

1 Like

Cant continue…

1 Like

If I understand the quest correctly, you have 3 areas where you need to interact with one of the pillars in each. This means you need to go to each area and interact with one, for a total of 3 times. However, if you interact with one in one area, no more in that area are interactable.

Check if you keep moving forward you can interact with another one. Try every single one if you have to :smiling_face_with_tear:

tried all of it.
Doesnt seem to work. :pensive:

Not just in the area marked on the map. There’s more pillars ahead :stuck_out_tongue:
(Pretty much that whole area before the bridge on the top left has pillars to interact with)
Could be a bug, but just make sure haha

1 Like

Yeah tried it all. Even in different channels and so and so.
But thanks for help.

1 Like

Oh that sucks then… Yeah, probably a bug then D:
I hope they fix it soon!

1 Like

This is just an issue with the interaction prompt not being displayed. While underground, press ‘G’ while next to the tower to interact with it and continue the quest.


thanks it worked

I did this quest 10min ago. Works fine