Lab Research slot lost

Hello!

Since the update, I experienced that my Stronghold Lab has lost a research slot. I have reached Lab Lv. 3 and yesterday I had 2 research slots available.
When logging in to the game now, there is only 1 research slot available.

Region: EUW
Server: Moonkeep

3 Likes

to make it easier for this problem to be addresed try to use the search function or the last list there multiple threads about this try to reply to this one:

opening up several threads about the same is slowing down the process

2 Likes

Sorry, I didn’t see that one here when I was browsing.
Thanks for the input

NP have a great day :slight_smile:

Hello @Methras.

Thank you for contact us in regard the research slot issue. I’m sorry for this situation.

The team is checking on this situation right now and they are working in order to fix it as soon as possible. In the meantime, can you please try this temporary fix:

Please let me know if worked for you.

Thank you in advance and best regards.

2 Likes

Hello!
Thank you for your answer. Yes, doing that did help me finish the tasks that had been completed, but is no help with starting new ones.

Happy to hear it is being worked on :slight_smile:

Thank you so much for the update @Methras.

I’m going to report this and start and investigation. Can you please share your character name?

Thank you in advance.

1 Like

Same issue on my account

1 Like