Login not possible


after server selection of Antares I would expect to see my character selection screen but it doesn’t appear. The server selection screen freezes and after a while the “An error has occured. Exiting the game.” message appears and the client collapses.

Server: Antares
Last char login: Belfana

Best Regards,


Hello @Teydin, welcome to the Lost Ark forums,

I’m sorry to hear about this issue with your game, before we start working on a solution I wanna know if you have done any sort of troubleshooting so I can take that into consideration?
I’ll be waiting!


Hello @Jormungandrh,

thanks for your reply. I checked the client for failures via Steam and tried to logon to another server with one character on it but got a queue and decided not to proceed. I also disabled my firewall and switched VPN client off and used the connection via my provider. Any other tasks to check?

Best Regards,


Understood, while I continue to research for a solution please try this:

  • Update your video and windows drivers.

  • Repair Easy Anti cheat ( Open Lost Ark Application in your Steam library and go to Settings →
    Manage → Browse Local Files > Open the AntiCheat Folder > Run the EasyAntiCheat_Setup
    executable file > Repair.

  • Relaunch the game.

Let me know if the issue persist after these steps!


@Jormungandrh The issue still persits. I was online beetween 12am and 1pm today, maybe this information helps?!

Would you mind contacting us via a live channel whenever you are available please? We need some personal information from you which is why we cannot handle it on a public forum.

You can reach us using the following link: Contact Us | Amazon Games

This issue seems to be something really specific which we don’t have “troubleshooting steps” and I do believe requesting an escalation with our developers might be the best option.

I do want to thank you for your understanding and patience.

Feel free to refer my colleagues to this forum post. I hope this helps, feel free to tag me if you need anything else.

Best of lucks and I wish you have an amazing week!


@Jormungandrh Thanks for your offer, it seems to be fixed by now. I completly uninstalled my drivers and and run the new ones again. After a system reboot the character selection screen appears and I’m able to login. Is maybe a very exceptional problem. Don’t know what issue solved it from the different checks I did.

1 Like

I’m happy to hear the issue was removed, thanks for the update! And have fun with in Arkesia!