Lost Ark doest load game after EAC gets done

Tried everything…What do i do? Shows up in task manager, but never loads.

Hello, I have same issue still can’t find solution.

Things that I tried:

-Re-installing the game.
-Verified Integrity of Game Files (multiple times)
-Restarted PC
-Left game running for couple of hours, still nothing.
-Repaired, uninstalled and re-installed EAC.
-Moved game files from one disc to another.
-Downloaded latest drivers.
-Updated Windows to latest version.
-Disabled all unnecessary programs through “msconfig”.
-I have no antivirus or VPN.

Maybe some of these can help you to solve your EAC problems, for others it helped.

GL.

Hi there

@A_D I’d like you to try the troubleshooting steps provided by @Indigo .

There are two additional troubleshooting step I’d like you to try:

  • Make sure your Firewall isn’t blocking the game
  • Try to reboot your computer with a “clean boot” to make sure there is no 3rd party software running which might be detected as “suspicious” by EAC. You can learn howto from here: How to perform a clean boot in Windows

At this point if the issue persist, it is best for you to reach us via chat to take a closer look at your issue and escalate it if necessary.

You can reach us here: Contact Us | Amazon Games

I hope this helps.

Tried all the normal and this is the only game thats doing it to me. Yall gotta figure something out. Missing time x\

I did all of the above been almost a week, EAC is screwing lotta polayers.
pda net i was told would trigger that crap easy anticheat. So i went just normal usb tether still nothing.

I gave up trying to fix the launch of the game.

Came back to Guild Wars 2, having a good time there :smiley:

ya i dont understand, worst thing i used was pdanet + which i turned off and still nothing

Diablo 2 Ressurrected cant get enough, and last epoch

Have they fixed this issue, i mean i paid for the game and cant even play it… This is rediculous.

This game ist right, they need to fix the game